Welcome to NeoOffice Forums
NeoOffice
 
Official online support site for NeoOffice

Trinity
· Home
· Private Messages
· Your Account


RSS Feeds
· NeoOffice Releases
· Forum Posts
· Beta Releases
· Headlines


Twitter Feeds
· @NeoOffice


Download NeoOffice
· Get NeoOffice
· Get the Latest Patch
· Language Packs
· User Guide
· User Guide Volume 2


Other Websites
· NeoOffice.org
· NeoWiki


Languages
Select Interface Language:



  
trinity.neooffice.org :: View topic - switching windows
 Forum FAQForum FAQ   SearchSearch   UsergroupsUsergroups   ProfileProfile   Private MessagesPrivate Messages   Log inLog in 

switching windows
Users who have purchased direct support within the last year can post
Goto page Previous  1, 2, 3, 4  Next
 
Post new topic   Reply to topic    trinity.neooffice.org Forum Index -> NeoOffice Support
View previous topic :: View next topic  
Author Message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11389
Location: California, USA

PostPosted: Tue Mar 23, 2010 11:10 am    Post subject: Reply with quote

Gust wrote:
The floating window seems to be a trigger here: if there are no floating windows, switching is normal. With floating windows, cycling is limited to the top-2. The cursor is causing the irritating floating window to appear when in a table. But without tables the same behaviour can be reproduced with the Styles & Formatting float.

Maybe it's an os x bug? On my Azerty keyboard, the shortcut used for switching is command+control+>


I still cannot reproduce this. I changed my system preferences to use Command-Control-> as the shortcut and then opened 3 new Writer documents. All have the Styles & Formatting window open and with or without tables I can cycle through all 3 documents.

Can you verify that you are have the latest Mac OS X system updates installed by selecting the Apple :: About This Mac menu and tell us what version is displayed?

Patrick
Back to top
View user's profile Send private message Visit poster's website
Gust
Councilperson


Joined: Oct 09, 2007
Posts: 137

PostPosted: Tue Mar 23, 2010 11:51 am    Post subject: Reply with quote

pluby wrote:
I still cannot reproduce this. I changed my system preferences to use Command-Control-> as the shortcut and then opened 3 new Writer documents. All have the Styles & Formatting window open and with or without tables I can cycle through all 3 documents.
To be correct I use command+control+< to cycle through windows. Strangely enough, when using command+control+> (which is the default azerty shortcut for cycling in reverse order) the issue does not play. Note that on an azerty layout ">" boils down to "shift+<" (so shift is used to mark the direction of the loop). (sorry, had some problems to get < display correctly)
pluby wrote:
Can you verify that you are have the latest Mac OS X system updates installed by selecting the Apple :: About This Mac menu and tell us what version is displayed?
10.6.2 intel
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11389
Location: California, USA

PostPosted: Tue Mar 23, 2010 12:34 pm    Post subject: Reply with quote

Gust wrote:
To be correct I use command+control+< to cycle through windows. Strangely enough, when using command+control+> (which is the default azerty shortcut for cycling in reverse order) the issue does not play. Note that on an azerty layout ">" boils down to "shift+<" (so shift is used to mark the direction of the loop). (sorry, had some problems to get < display correctly)


I can now reproduce this bug with the shortcut to set to either Command-Control-<or>. I had forgotten to hold the Shift key when I was setting the shortcut in the System Preferences application.

I suspect that that Shift key is the cause so I will investigate this bug and post when I have any news to report.

Patrick
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11389
Location: California, USA

PostPosted: Tue Mar 23, 2010 1:59 pm    Post subject: Reply with quote

I think that I have fixed this bug. I found that this bug only occurs when your "next window in application" system shortcut includes the Shift key.

Can you install the following test patch and tell us if the fix works for you?:

Intel:
http://joe.neooffice.org/test/NeoOffice-3.0.2-Patch-2-Test-4-Intel.dmg

PowerPC:
http://joe.neooffice.org/test/NeoOffice-3.0.2-Patch-2-Test-4-PowerPC.dmg

Patrick
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11389
Location: California, USA

PostPosted: Thu Mar 25, 2010 9:35 am    Post subject: Reply with quote

Have you had a chance to try the test patch? If so, are there still any problems cycling through the windows?

If the test patch fixes the bug for you, let me know and I will include it in the next official NeoOffice 3.0.2 patch.

Patrick
Back to top
View user's profile Send private message Visit poster's website
Gust
Councilperson


Joined: Oct 09, 2007
Posts: 137

PostPosted: Thu Mar 25, 2010 12:46 pm    Post subject: Reply with quote

pluby wrote:
Have you had a chance to try the test patch? If so, are there still any problems cycling through the windows?

If the test patch fixes the bug for you, let me know and I will include it in the next official NeoOffice 3.0.2 patch.
I've tested the patch but unfortunately it doesn't solve the issue here.

To be clear, the issue happens with me when cycling through windows without holding the shift key (command-control-&lt;). When I hold the shift key (i.e. reverse cycle with command-control-shift-&lt;), the problem doesn't arise.

Probably to reproduce my setting as closely as possible you should use your German QWERTZ keyboard (which has an additional key next to the left shift button) and set the keyboard locale to Belgian. But there's a caveat here, as I've seen Apple varying the windows switching shortcut over OS versions as well as keyboard hardware makes for the Belgian keyboard layout: on some model-os combinations it's command+control+&lt;, whereas for other it is command+&lt;. So not sure if you can reproduce this one.
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11389
Location: California, USA

PostPosted: Thu Mar 25, 2010 2:36 pm    Post subject: Reply with quote

Gust wrote:
To be clear, the issue happens with me when cycling through windows without holding the shift key (command-control-&lt;). When I hold the shift key (i.e. reverse cycle with command-control-shift-&lt;), the problem doesn't arise.


So I solved a different bug. For me the reverse cycle bug looked the same as your bug but clearly they are different bugs.

I will use your steps to reproduce and fix your bug and I will post a test patch for you to try when I have a fix.

Patrick
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11389
Location: California, USA

PostPosted: Fri Mar 26, 2010 11:56 am    Post subject: Reply with quote

I think that I have fixed this bug. The Control key that you press when using a Belgian keyboard was what was causing our fix for bug 3557 to not work for you.

Can you install the following test patch and tell us if the fix works for you?:

Intel:
http://joe.neooffice.org/test/NeoOffice-3.0.2-Patch-2-Test-5-Intel.dmg

PowerPC:
http://joe.neooffice.org/test/NeoOffice-3.0.2-Patch-2-Test-5-PowerPC.dmg

Patrick
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11389
Location: California, USA

PostPosted: Sat Mar 27, 2010 3:50 pm    Post subject: Reply with quote

I forgot to add that I was hoping to release NeoOffice 3.0.2 Patch 3 this Monday, 29 March 2010, with my latest fix so if this bug is fixed for you in the latest test patch, please let us know and we will release the fix on Monday.

Patrick
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11389
Location: California, USA

PostPosted: Mon Mar 29, 2010 9:45 am    Post subject: Reply with quote

FYI. I have included the fix in NeoOffice 3.0.2 Patch 3. You can download the patch from the NeoOffice patch download page.

If the bug still occurs in NeoOffice 3.0.2 Patch 3, please let us know and we will do more investigation of this bug.

Patrick
Back to top
View user's profile Send private message Visit poster's website
Gust
Councilperson


Joined: Oct 09, 2007
Posts: 137

PostPosted: Tue Mar 30, 2010 1:29 pm    Post subject: Reply with quote

pluby wrote:
If the bug still occurs in NeoOffice 3.0.2 Patch 3, please let us know and we will do more investigation of this bug.
I've downloaded and installed patch 3, but unfortunately the issue is still there...
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11389
Location: California, USA

PostPosted: Tue Mar 30, 2010 4:54 pm    Post subject: Reply with quote

Gust wrote:
I've downloaded and installed patch 3, but unfortunately the issue is still there...


I must be doing something wrong to reproduce the bug. What I did was set the keyboard to Belgian in the Mac OS X menubar and change the preferred language to German in the System Preferences application's International icon. Then, I launched NeoOffice, opened the Styles & Formatting floating window, and opened a total of 3 empty Writer documents. Since my keyboard was set to Belgian, the shortcut for cycling through windows is the Control-Command-&lt; keys. Pressing those keys cycled through the windows normally with the fix that was included in Patch 3 but without the fix the bug occurred.

Is there anything that I am missing? Also, did you upgrade to Mac OS X 10.6.3 this week? If so, I tested my fix only on 10.6.2 so maybe my fix only works with 10.6.2.

Patrick
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11389
Location: California, USA

PostPosted: Wed Mar 31, 2010 8:13 am    Post subject: Reply with quote

pluby wrote:
Is there anything that I am missing? Also, did you upgrade to Mac OS X 10.6.3 this week? If so, I tested my fix only on 10.6.2 so maybe my fix only works with 10.6.2.


FYI. I just upgraded to Mac OS X 10.6.3 and I cannot reproduce this using Belgian keyboard and the preferred language set to German so I don't think this is a 10.6.3 issue. Instead, there must be some setting on your machine that is different from my settings.

Please let us know if there is any setting other than using the Belgian AZERTY keyboard and German language that I need to set.

Patrick
Back to top
View user's profile Send private message Visit poster's website
Gust
Councilperson


Joined: Oct 09, 2007
Posts: 137

PostPosted: Sat Apr 03, 2010 5:58 am    Post subject: Reply with quote

pluby wrote:
Please let us know if there is any setting other than using the Belgian AZERTY keyboard and German language that I need to set.
I'm using Belgian keyboard with the language set to Dutch (Nederlands) on OS X 10.6.3. I haven't been testing so far for different locale-settings with respect to the window switching issue.
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11389
Location: California, USA

PostPosted: Sat Apr 03, 2010 8:04 am    Post subject: Reply with quote

Gust wrote:
I'm using Belgian keyboard with the language set to Dutch (Nederlands) on OS X 10.6.3. I haven't been testing so far for different locale-settings with respect to the window switching issue.


Can you take a screen snapshot of the window cycling shortcut setting and attach the screen snapshot?

To do this, launch the System Preferences application, click on the Keyboard icon, then click on the Keyboard Shortcuts item in the list that appears. Search for the "Move focus to next window..." keyboard shortcut.

When you find that keyboard shortcut, take a screen snapshot of that shortcut by pressing the Command-Shift-4 keys. The cursor will change. Drag the cursor to select the entire keyboard shortcut entry. When you let go of the mouse, a "Picture <some>.png" file will be created on your Desktop. Please attach that .png file.

Patrick
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    trinity.neooffice.org Forum Index -> NeoOffice Support All times are GMT - 7 Hours
Goto page Previous  1, 2, 3, 4  Next
Page 3 of 4

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.06 Seconds