Welcome to NeoOffice Forums
NeoOffice
 
Official online support site for NeoOffice

Trinity
· Home
· Private Messages
· Your Account


RSS Feeds
· NeoOffice Releases
· Forum Posts
· Beta Releases
· Headlines


Twitter Feeds
· @NeoOffice


Download NeoOffice
· Get NeoOffice
· Get the Latest Patch
· Language Packs
· User Guide
· User Guide Volume 2


Other Websites
· NeoOffice.org
· NeoWiki


Languages
Select Interface Language:



  
trinity.neooffice.org :: View topic - Update screen shows e-mail address black on black
 Forum FAQForum FAQ   SearchSearch   UsergroupsUsergroups   ProfileProfile   Private MessagesPrivate Messages   Log inLog in 

Update screen shows e-mail address black on black
Users who have purchased direct support within the last year can post
Goto page Previous  1, 2
 
Post new topic   Reply to topic    trinity.neooffice.org Forum Index -> NeoOffice Support
View previous topic :: View next topic  
Author Message
benst
Captain


Joined: May 25, 2004
Posts: 72
Location: The Netherlands

PostPosted: Sat May 05, 2012 1:53 pm    Post subject: Reply with quote

Bug report filed. Thanks Patrick!

Ben
Back to top
View user's profile Send private message
ovvldc
Captain Naiobi


Joined: Sep 13, 2004
Posts: 2349
Location: Zürich, CH

PostPosted: Thu May 10, 2012 12:20 am    Post subject: Reply with quote

They may not have listened, as I just updated to the new Safari release and saw weird backgrounds in form fields somewhere..
_________________
"What do you think of Western Civilization?"
"I think it would be a good idea!"
- Mohandas Karamchand Gandhi
Back to top
View user's profile Send private message
benst
Captain


Joined: May 25, 2004
Posts: 72
Location: The Netherlands

PostPosted: Thu May 10, 2012 1:37 am    Post subject: Reply with quote

It was probably too late to fix in time for this release. But they picked it up and came back for some more information about my setup. So it is in the works I presume.

Ben
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11385
Location: California, USA

PostPosted: Sat May 12, 2012 7:23 pm    Post subject: Reply with quote

I now see this Apple bug on both Mac OS X 10.6.8 and 10.7.4 after installing the latest Apple system updates.

What is stange is that I found out is that this bug only occurs when my test application is compiled on Mac OS X 10.5 and then run on 10.6.8 or 10.7.4. But if the test application is compiled on 10.6.8, the bug does not occur.

Patrick

_________________
NeoOffice engineer
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11385
Location: California, USA

PostPosted: Sat May 12, 2012 11:11 pm    Post subject: Reply with quote

FYI. I found a way to stop this Apple bug from occurring using a small tweak to our website. I added the following CSS to both our main website as well as our NeoOffice Mobile website:

Code:
input[type=text] {
border-width: 1px;
}
input[type=password] {
border-width: 1px;
}


Let me know if you still see the black background bug on your machine. You can test my fix by selecting the NeoOffice's Mobile :: Open NeoOffice Mobile menu and in the window that appears, press the "Forgot Password?" button. If my fix works, the text field on that page should have a white background.

Patrick

_________________
NeoOffice engineer
Back to top
View user's profile Send private message Visit poster's website
benst
Captain


Joined: May 25, 2004
Posts: 72
Location: The Netherlands

PostPosted: Sun May 13, 2012 3:00 am    Post subject: Reply with quote

Hi Patrick,

That CSS change did the trick. Looks fine now.

Kind regards,
Ben
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11385
Location: California, USA

PostPosted: Sun May 13, 2012 10:36 am    Post subject: Reply with quote

Thanks for testing this change. Thankfully it worked because I doubt that Apple will fix their bug since it only occurs in code compiled on Mac OS X 10.5 which is now unsupported by Apple.

Hopefully, this CSS change will also be useful for other applications that use Apple's WebKit functions like NeoOffice does.

Patrick

_________________
NeoOffice engineer
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    trinity.neooffice.org Forum Index -> NeoOffice Support All times are GMT - 7 Hours
Goto page Previous  1, 2
Page 2 of 2

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.05 Seconds