Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2017? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - build problem
build problem
 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> NeoOffice/C Development
View previous topic :: View next topic  
Author Message
Chris C
Guest





PostPosted: Fri Nov 14, 2003 6:23 am    Post subject: build problem Reply with quote

So, I am doing a build of the new Neo using the new instructions on Schlesi's site... and I get this error:

Making: ../../../unxmacxp.pro/slb/salextra_x11osx.lib
echo unxmacxp.pro/slo/osxlocale.o | xargs -n1 > ../../../unxmacxp.pro/slb/salextra_x11osx.lib
cp -f /neooffice/solenv/src/default_description.xml ../../../unxmacxp.pro/misc/salextra_x11osx_mxp.xml
xml2cmp -func ../../../unxmacxp.pro/misc/salextra_x11osx_mxp_description.cxx ../../../unxmacxp.pro/misc/salextra_x11osx_mxp.xml
dyld: xml2cmp can't open library: @executable_path/libstlport_gcc.dylib.4.5 (No such file or directory, errno = 2)
Trace/BPT trap
dmake: Error code 133, while making '../../../unxmacxp.pro/misc/salextra_x11osx_mxp_description.cxx'
---* TG_SLO.MK *---

ERROR: Error 65280 occurred while making /neooffice/sal/systools/macxp_extras/x11osx
dmake: Error code 1, while making 'build_all'



uhhmmmmm.... HELP!!!

we now return you to your normal programing...
Back to top
schlesi
Oracle


Joined: Jun 07, 2003
Posts: 234
Location: near Cologne, Germany

PostPosted: Fri Nov 14, 2003 1:12 pm    Post subject: Reply with quote

Chris,

until you got a qualified answer from Ed or Dan Wink , I'd suggest that you are erasing the folders /neooffice/solver/645/unxmacxp.pro and /neooffice/stlport/unxmacxp.pro , make a new cvs-get and try a new build.

Thomas
Back to top
View user's profile Send private message AIM Address
Chris C
Guest





PostPosted: Fri Nov 14, 2003 2:48 pm    Post subject: ok Reply with quote

Thanks Thomas. I will dump the offending folders and fire up cervisia and start the build over.

Other then that one problem everything seemed to be going fine.

There seems to be a whole lot of new stuff from the last time I did a build of Neo, and I am looking forward to seeing the end result.

Thanks for the help
Back to top
jakeOSX
Ninja
Ninja


Joined: Aug 12, 2003
Posts: 1373

PostPosted: Sun Nov 16, 2003 12:40 pm    Post subject: Reply with quote

ok, i updated my CVS today to give the build a second shot and got this error, it is very close to chris's but there are some differences...

Code:
In file included from ../stlport/stl/_construct.h:43,
                 from ../stlport/stl/_alloc.h:68,
                 from ../stlport/memory:28,
                 from dll_main.cpp:38:
../stlport/stl/_iterator_base.h:50: parse error before `,' token
../stlport/stl/_iterator_base.h:54: template declaration of `typedef _Tp
   _STL::value_type'
../stlport/stl/_iterator_base.h:54: confused by earlier errors, bailing out
make: *** [../lib/obj/GCC/ReleaseD/dll_main.o] Error 1
dmake:  Error code 2, while making './unxmacxp.pro/misc/build/so_built_so_stlport'
---* TG_SLO.MK *---

ERROR: Error 65280 occurred while making /neooffice/stlport
dmake:  Error code 1, while making 'build_all'


machine info:
PowerMac 800, 10.2.6 Dev Tools installed (the ones that were on the CD, not any new ones on the site)
Back to top
View user's profile Send private message
schlesi
Oracle


Joined: Jun 07, 2003
Posts: 234
Location: near Cologne, Germany

PostPosted: Sun Nov 16, 2003 1:18 pm    Post subject: Reply with quote

Chris & Jacob,

I've an idea. May be you need the gcc-3-compiler. Jaguar has the gcc-2-compiler.

You can download it from http://developer.apple.com after registering as a developer for free (Download Software/Developer Tools/August 2003 gcc Updater).

After installing, open a command line an type "sudo gcc_select 3" in terminal.

A "gcc --version" in terminal should show you a gcc 3.x". After that, try again building NeoOffice. Please let me know, if it helps.

Thomas
Back to top
View user's profile Send private message AIM Address
Chris C
Guest





PostPosted: Sun Nov 16, 2003 9:05 pm    Post subject: Reply with quote

Thomas.

Got panther and the included Dev tools installed Gcc is 3.3 and it was at the time of the error.

I did another CVS pull and restarted. Got the same error.
Back to top
schlesi
Oracle


Joined: Jun 07, 2003
Posts: 234
Location: near Cologne, Germany

PostPosted: Mon Nov 17, 2003 11:06 am    Post subject: Another shoot in the dark Reply with quote

Chris,

another shoot in the dark:

May be a problem with access permissions. Try the following:

Open a terminal
Enter "sudo chmod -R 777 /neooffice", enter your password.

If that doesn't help, delete the folders /neooffice/stlport and /neooffice/sal, make a new cvs-get, do the "chmod" from above again and try a new build.

Thomas
Back to top
View user's profile Send private message AIM Address
Chris C
Guest





PostPosted: Tue Nov 18, 2003 4:01 pm    Post subject: Reply with quote

so far it looks like it is working...
Back to top
schlesi
Oracle


Joined: Jun 07, 2003
Posts: 234
Location: near Cologne, Germany

PostPosted: Tue Nov 18, 2003 9:49 pm    Post subject: Reply with quote

Nice Very Happy

Thomas
Back to top
View user's profile Send private message AIM Address
Chris C
Guest





PostPosted: Tue Nov 18, 2003 11:30 pm    Post subject: Reply with quote

well it seems to have gotten past the previous hang up.

I do have a question that will probably answer itself by the time someone reads this but just in case...

I am to this point
Making: ../unxmacxp.pro/lib/libxcr645mxp.dylib.jnilib
create-bundle: ../unxmacxp.pro/lib/libxcr645mxp.jnilib successfully created
/neooffice/solenv/bin/checkdll.sh -L../unxmacxp.pro/lib -L/neooffice/solver/645/unxmacxp.pro/lib -L/usr/lib ../unxmacxp.pro/lib/libxcr645mxp.dylib
Checking DLL ../unxmacxp.pro/lib/libxcr645mxp.dylib ...


and it has been sitting there for over an hour on my 450 G3 doing nothing that I can see. The process shows active and nothing has crashed. I can watch it pick up a bit more RAM and CPU in activity viewer so it is still doing something.

I am just wondering if that checking DLL thing does take forever or whether I should kill the process and dmake again?
Back to top
Chris C
Guest





PostPosted: Wed Nov 19, 2003 1:32 am    Post subject: Reply with quote

yeah it answered itself... just after posting I watched the processes go from the active column to the inactive. So I let it sit there for another half hour or so with no change and had to kill the window and start over.

So far so good. No idea why the process would just lie down on the job like that and maybe it is supposed to, just did not look right.
Back to top
Terry Teague
Guest





PostPosted: Wed Nov 19, 2003 1:36 am    Post subject: Re: build hang Reply with quote

Chris C wrote:
well it seems to have gotten past the previous hang up.

I do have a question that will probably answer itself by the time someone reads this but just in case...

I am to this point
Making: ../unxmacxp.pro/lib/libxcr645mxp.dylib.jnilib
create-bundle: ../unxmacxp.pro/lib/libxcr645mxp.jnilib successfully created
/neooffice/solenv/bin/checkdll.sh -L../unxmacxp.pro/lib -L/neooffice/solver/645/unxmacxp.pro/lib -L/usr/lib ../unxmacxp.pro/lib/libxcr645mxp.dylib
Checking DLL ../unxmacxp.pro/lib/libxcr645mxp.dylib ...


and it has been sitting there for over an hour on my 450 G3 doing nothing that I can see. The process shows active and nothing has crashed. I can watch it pick up a bit more RAM and CPU in activity viewer so it is still doing something.

I am just wondering if that checking DLL thing does take forever or whether I should kill the process and dmake again?

You're hosed Crying or Very sad The same problem can occur with current builds of OOo 1.1.x, particularly if you are using Fink. This problem is currently being discussed on the Porting mailing list. A partial fix is to unsetenv some environment variables relating to dynamic linking, that might have been set by Fink or other. Suggest browsing the Porting mailing list archives.

Regards, Terry
Back to top
Chris C
Guest





PostPosted: Wed Nov 19, 2003 3:30 am    Post subject: Reply with quote

joygasm! I will take a look at the mailing list...errrggggg

Thanks Terry.
Back to top
Chris C
Guest





PostPosted: Wed Nov 19, 2003 6:11 am    Post subject: Reply with quote

well after reading the list I found the entry. It looks like Ben Reeds fink prebinding stuff is prolly behind it. I disabled it. Dumped the build to that point to avoid the alluded to problems down the road later in the build and am pulling another CVS.....

I am not sure if I need to apply a patch at this point after the pull is done or not. I hope not, because I can't remember if I ever knew how to apply one of those in the first place Smile

I am now at the point that I REALLY want to see this thing run!
Back to top
chris c
Guest





PostPosted: Mon Nov 24, 2003 11:53 pm    Post subject: Reply with quote

well. no joy. Tossed it all out and dl'd the prebuilt one off of BT.

And wouldn't you know it! That will not fire over. It trys to but soffice.bin crashes. the crash log says:
OS Version: 10.3.1 (Build 7C107)

Command: soffice.bin (/Applications/NeoOffice.app/Contents/Resources/program/soffice.bin)
PID: 2271
Thread: 0

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000008

Thread 0 Crashed:
#0 0x0101dc78 in String::CompareTo(String const&, unsigned short) const (String::CompareTo(String const&, unsigned short) const + 16)
#1 0x005d6cac in GetFontWeightFromFontName(String*) (GetFontWeightFromFontName(String*) + 372)
#2 0x005d6ee4 in SFUGetSystemFontList() (SFUGetSystemFontList() + 464)
#3 0x005d97d8 in SalGraphics::GetDevFontList(ImplDevFontList*) (SalGraphics::GetDevFontList(ImplDevFontList*) + 76)
#4 0x004f0678 in OutputDevice::ImplInitFontList() const (OutputDevice::ImplInitFontList() const + 76)
#5 0x0056be20 in Window::ImplUpdateGlobalSettings(AllSettings&, unsigned char) (Window::ImplUpdateGlobalSettings(AllSettings&, unsigned char) + 72)
#6 0x0056d1b0 in Window::ImplInit(Window*, long long, SystemParentData*) (Window::ImplInit(Window*, long long, SystemParentData*) + 1316)
#7 0x00549918 in Dialog::ImplInit(Window*, long long) (Dialog::ImplInit(Window*, long long) + 472)
#8 0x0054ed3c in MessBox::MessBox[unified](Window*, ResId const&) (MessBox::MessBox[unified](Window*, ResId const&) + 276)
#9 0x0054ff60 in QueryBox::QueryBox[unified](Window*, ResId const&) (QueryBox::QueryBox[unified](Window*, ResId const&) + 52)
#10 0x0000f8d4 in desktop::Lockfile::execWarning() const (desktop::Lockfile::execWarning() const + 200)
#11 0x0000f124 in desktop::Lockfile::check() (desktop::Lockfile::check() + 56)
#12 0x000072e0 in desktop::Desktop::Main() (desktop::Desktop::Main() + 224)
#13 0x00489538 in SVMain() (SVMain() + 8Cool
#14 0x005df5a8 in main (main + 56)
#15 0x000027b4 in _start (crt.c:267)
#16 0x00002628 in start (start + 4Cool

Thread 1:
#0 0x9004364c in accept (accept + 12)
#1 0x01927c34 in osl_acceptPipe (osl_acceptPipe + 44)
#2 0x0009b500 in vos::OPipe::accept(vos::OStreamPipe&) (vos::OPipe::accept(vos::OStreamPipe&) + 36)
#3 0x00011140 in desktop::OfficeIPCThread::run() (desktop::OfficeIPCThread::run() + 56)
#4 0x00096cf8 in vos::_cpp_OThread_WorkerFunction(void*) (vos::_cpp_OThread_WorkerFunction(void*) + 36)
#5 0x0192b5b4 in osl_thread_start_Impl (osl_thread_start_Impl + 320)
#6 0x900247e8 in _pthread_body (_pthread_body + 40)

PPC Thread State:
srr0: 0x0101dc78 srr1: 0x0000d930 vrsave: 0x00000000
cr: 0x84044222 xer: 0x0000000e lr: 0x005d6ee4 ctr: 0x0101dc68
r0: 0x00000000 r1: 0xbffff100 r2: 0x02146790 r3: 0x00000008
r4: 0x021467b8 r5: 0x0000ffff r6: 0x00000008 r7: 0x00000004
r8: 0x022028d3 r9: 0x00000001 r10: 0x022008cf r11: 0x0061442c
r12: 0x0101dc68 r13: 0x00000000 r14: 0x00000000 r15: 0x00000000
r16: 0x00000000 r17: 0x00000000 r18: 0x00000000 r19: 0x00000001
r20: 0x02146790 r21: 0x02143aa0 r22: 0x03850200 r23: 0x02141410
r24: 0x00000001 r25: 0x021467b8 r26: 0x00000004 r27: 0x00000001
r28: 0x021467c0 r29: 0x00000000 r30: 0x021467b0 r31: 0x005d979c








any ideas on how to fix this?
Back to top
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> NeoOffice/C Development All times are GMT - 7 Hours
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.04 Seconds