Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2017? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - NeoOffice always triggers setup
NeoOffice always triggers setup
 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> NeoOffice/C Testing
View previous topic :: View next topic  
Author Message
ssa
Agent


Joined: Sep 29, 2003
Posts: 12
Location: Hamburg, Germany

PostPosted: Wed Jan 21, 2004 3:33 pm    Post subject: NeoOffice always triggers setup Reply with quote

Hi,

I'm still having problems getting NeoOffice to launch. Without displaying anything it just triggers setup to run - which then crashes...

So it seems to me that my installation is corrupt somehow, which leads to running setup in order to fix it.

Did anyone encounter similar problems ?

Stephan
Back to top
View user's profile Send private message
schlesi
Oracle


Joined: Jun 07, 2003
Posts: 234
Location: near Cologne, Germany

PostPosted: Thu Jan 22, 2004 11:01 am    Post subject: Reply with quote

Stephan,

a shot in the dark: you could try to set recursively the owner of the NeoOfficeJ.app to your user name.

Thomas
Back to top
View user's profile Send private message AIM Address
Guest






PostPosted: Thu Jan 22, 2004 3:17 pm    Post subject: Reply with quote

Stephan,

First thing I would check would be your .sversionrc file... Is it pointing to ......../NeoOffice.app/Contents/MacOS ? Ed had some scripts that dealt with this, but if you're directly launching the executable then this might be an issue.

Dan
Back to top
OPENSTEP
The One
The One


Joined: May 25, 2003
Posts: 4752
Location: Santa Barbara, CA

PostPosted: Fri Jan 23, 2004 12:30 am    Post subject: Reply with quote

Chances are if you're getting the setup being triggered you're a "first time" previewer...er...tester...er...examiner of unfinished software...er... Wink

As Dan mentioned, there's some custom setup bash scripts living inside of the bundle that would happily autoconfigure Neo for new user accounts or for being randomly relocated on a hard drive. Unfortunately all of these scripts were broken with the 1.1 update Sad The only thing I can think of offhand is to try to create your .sversionrc file manually. I know the grep and replace stuff in the scripts...

If you've ever installed OOo 1.0.3 or OOo 1.1, you'll have a file in your home directory named ".sversionrc" (you can't see it with the Finder, you need to use a Terminal). Edit this file and add a line started with:

Code:

NeoOffice -1=file://


and after the second slash include the full path to the Resources directory of the Neo bundle including the initial slash of the pathname (e.g. there should be three slashes after file:).

ed
Back to top
View user's profile Send private message Visit poster's website AIM Address
ssa
Agent


Joined: Sep 29, 2003
Posts: 12
Location: Hamburg, Germany

PostPosted: Sun Jan 25, 2004 12:28 pm    Post subject: Reply with quote

I finally got it running ! Patching .sversionrc was actually needed to hinder setup from trying to fix my installation... Thanks for the hint.

But then soffice.bin crashed immediately after launching all the time, and I saw that it couldn't manage to load some resources. It turned out to be the iso64501.res which wasn't installed but needed by the registration dialog. Copying it over from solver or the offmgr output tree helped. How is it suposed to work ? I saw there is a neo645.res and ooo645.res created in offmgr but only the latter one found its way into the installation. But at runtime the iso resource is searched, so may be there are some compile switches/defines missing ?

Stephan
Back to top
View user's profile Send private message
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> NeoOffice/C Testing All times are GMT - 7 Hours
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.03 Seconds