Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2017? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - strange menu behavior
strange menu behavior
 
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Testing
View previous topic :: View next topic  
Author Message
jakeOSX
Ninja
Ninja


Joined: Aug 12, 2003
Posts: 1373

PostPosted: Mon Feb 16, 2004 6:34 pm    Post subject: strange menu behavior Reply with quote

Patrick

The powermac has a version of Neo/J which started at 0.7 and went patch wise to 0.8. I've never seen this on the powermac.

the iBook has 0.8 downloaded fresh and installed on 10.2.8. Recently, when i start it up the word 'NeoOffice' and the apple on the menu won't appear until i click on the bar itself. then they appear and stay there like normal.

i don't think this happened when i first installed it. i recently installed oo.o/x11 1.0.3 and then oo.o 1.1 as well, just in case that may have some cause in this.

then again, it could just be me. =)

-j
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11907
Location: California, USA

PostPosted: Mon Feb 16, 2004 7:45 pm    Post subject: Reply with quote

Jake,

Are there any messages in Console.app? Java creates the menu and Java being Carbon-based, I have seen NeoJ on rare occasions get stuck in the background.

BTW, do you have "patch-5" for NeoJ 0.8 installed? The early patches had a reworking of the event dispatching to prevent some other bugs and I wonder if they are related.

Patrick
Back to top
View user's profile Send private message Visit poster's website
jakeOSX
Ninja
Ninja


Joined: Aug 12, 2003
Posts: 1373

PostPosted: Mon Feb 16, 2004 8:08 pm    Post subject: Reply with quote

the version i have is just the 0.8 install, no patches. I checked the consul and didn't see anything that looked like it was in reference to neo/j. i did open and close the prog a few times but nothing came up in the consul.

i did notice something, however. If i quit using the osx menu, about half the time the program crashes rather than quits. if i use the neo menu it quits just fine.
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11907
Location: California, USA

PostPosted: Mon Feb 16, 2004 9:02 pm    Post subject: Reply with quote

The crashing leads me to believe that this might be related to the event dispatching problems that I fixed in the early NeoJ 0.8 patches (the mouse-click bug was a particularly nasty one).

Can you install "patch-5" and see if this problem still occurs?

Patrick
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Testing All times are GMT - 7 Hours
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.02 Seconds