Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Problems after upgrading to Sierra or High Sierra? Try these steps
Problems after upgrading to NeoOffice 2017? Try these steps
Download or installation problems? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - Problem with Auto Correct
Problem with Auto Correct
 
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Releases
View previous topic :: View next topic  
Author Message
coffeerings
Blue Pill


Joined: Oct 04, 2006
Posts: 2

PostPosted: Wed Oct 18, 2006 8:43 pm    Post subject: Problem with Auto Correct Reply with quote

Even though I have the options selected that I want it to do, Neo Office doesn't do them. For example, when I type --, I have the option selected that should turn it into one long dash automatically, but it's not doing it. Help? It also does this with the option to "replace bullets with: (a bullet)". It's like it's not observing any of the options I have selected. I'm a new user and so far I'm finding it really unfriendly. Sad
Back to top
View user's profile Send private message
sardisson
Town Crier
Town Crier


Joined: Feb 01, 2004
Posts: 4588

PostPosted: Wed Oct 18, 2006 9:23 pm    Post subject: Reply with quote

Try moving aside your ~/Library/Preferences/NeoOffice-2.x folder and then launching Neo and seeing if the autocomplete works then (configuring the options if needed). I've noticed that this section of prefs seems especially prone to random "corruption" Sad

Smokey

_________________
"[...] whether the duck drinks hot chocolate or coffee is irrelevant." -- ovvldc and sardisson in the NeoWiki
Back to top
View user's profile Send private message Visit poster's website
coffeerings
Blue Pill


Joined: Oct 04, 2006
Posts: 2

PostPosted: Wed Oct 18, 2006 10:19 pm    Post subject: Reply with quote

Thank you SO much, that seemed to fix it. As for the folder that I moved aside (I moved it to the desktop)-- should I delete it, or move it back, or...? I wasn't really sure. Thanks again!
Back to top
View user's profile Send private message
sardisson
Town Crier
Town Crier


Joined: Feb 01, 2004
Posts: 4588

PostPosted: Wed Oct 18, 2006 10:59 pm    Post subject: Reply with quote

Since none of us knows what file among the 500 Wink contains the corrupt settings, you should probably delete it.

I've only had this sort of bug happen once or twice, but I've gotten in the habit of making an archive of a known-good preferences folder (Ctrl-click on the ~/Library/Preferences/NeoOffice-2.x folder in the Finder and choose "Create Archive..." from the context menu) so that if I ever have corrupt prefs again, I can restore a known-good set and not have to re-enter all my settings.

Smokey

_________________
"[...] whether the duck drinks hot chocolate or coffee is irrelevant." -- ovvldc and sardisson in the NeoWiki
Back to top
View user's profile Send private message Visit poster's website
Lorinda
Captain Mifune


Joined: Jun 20, 2006
Posts: 2051
Location: Midwest, USA

PostPosted: Thu Oct 19, 2006 6:04 am    Post subject: Reply with quote

Smokey's suggestion about archiving preferences is an excellent one.

Having just had to pull my preferences last night due to a different bug/corruption, I actually have to disagree slightly with him about trashing all your old preferences, though. If you have defined custom autotexts or added any templates, (or if you want to keep your backups) you probably don't want to trash all your preferences.

This is what I did to isolate the corrupted folder in preferences, so I could save the others:

1. I made a copy (in Finder File>Duplicate) of my old (on the desktop) preferences folder--this was in case I messed up in the process.
2. I selected half of the folders in the users folder of the old preferences folder and drug them into the new (uncorrupted) folder (~/Library/NeoOffer/user). When it warned me that this will replace folders of the same name, I clicked "ok"
3. I restarted NeoOffice and checked to see if the "bug" reappeared. (In my case it was a problem with the save dialog). Then I quit Neo.
4. If it did not reappear, this meant that that half of the preferences were ok. In my case, the first half I put back in (the "bottom" half in list view) were o.k. If the bug appears in the first half for you, skip to 6.
5. I put the other half of the preferences files back and restarted Neo. That's when the bug appeared.
6. I quit Neo I pulled this half (the one with a corruption somewhere) back onto the desktop.
7. I put one folder now on the desktop back in Library>Preferences>NeoOffice>user, restarted Neo, and checked for the bug.
8. I repeated this until I found the offending folder (in my case config). There didn't appear to be anything vital to my work in the old config folder, so I trashed the whole folder. If it had been my templates folder, I would have continued this process with the files in the folder.

If you know that there are only a few folders that contain work you don't want to lose (e.g. autotext, templates or backup), you could try just dragging those back in one at a time and see if they create problems.

On the other hand, if you haven't made any major changes to autotext or templates, Smokey's right--just trash them all! Smile
Back to top
View user's profile Send private message
sardisson
Town Crier
Town Crier


Joined: Feb 01, 2004
Posts: 4588

PostPosted: Thu Oct 19, 2006 10:55 am    Post subject: Reply with quote

Good point; I had forgotten that templates and other non-preference files are stored in that folder as well Sad (Were OOo designed as a Mac app, those things would end up in Application Support instead....)

Smokey

_________________
"[...] whether the duck drinks hot chocolate or coffee is irrelevant." -- ovvldc and sardisson in the NeoWiki
Back to top
View user's profile Send private message Visit poster's website
vicjoe
Captain


Joined: Oct 31, 2005
Posts: 56
Location: Victoria BC Canada

PostPosted: Wed Jul 25, 2007 2:16 pm    Post subject: autoformat and em dashes Reply with quote

coffeerings refers to replacing -- with a "long dash" but doesn't mention which one, em dash (the correct substitute) or an en dash. Here's what I've found:

When pasting text in to NeoOffice from e.g. an e-mail message, where the writer had used " -- " to indicate a pause that in correct word processing typography would be an 'em dash' if one then chooses "Autoformat", the expectation is that fake quotes and apostrophes (really inch and feet marks aka hash marks) will be replaced by the true 'curly' characters. And so the program does. But, the default replacement for " -- ", unlike e.g. MS Word for Mac, is incorrect. Instead of inserting an em dash (shift-option-dash on the Mac keyboard) it retains the spaces and inserts an en dash. An en dash is not used as a pause in written communication, it is used to indicate a range, usually numeric, as in 2004 (en dash here) 2005. I don't know if this can be corrected or if it is in the Ooo code, but it is wrong and hence detracts from the utility of the program for those who are not typographically challenged. (Because Mac users have always more easily been able to access these "extended characters" they are more likely to be aware of the issue than e.g. Win or Linux users).

I don't see any way to modify the Replace Dashes preference. Tools>Autocorrect>Option has the "Edit" button greyed out when the "Replace dashes" entry is highlighted. Is there a solution to this I have overlooked?
Back to top
View user's profile Send private message
doctype
Oracle


Joined: Dec 08, 2005
Posts: 291
Location: Berlin, Germany

PostPosted: Wed Jul 25, 2007 2:45 pm    Post subject: Re: autoformat and em dashes Reply with quote

vicjoe wrote:
But, the default replacement for " -- ", unlike e.g. MS Word for Mac, is incorrect. Instead of inserting an em dash (shift-option-dash on the Mac keyboard) it retains the spaces and inserts an en dash. An en dash is not used as a pause in written communication, it is used to indicate a range, usually numeric, as in 2004 (en dash here) 2005. I don't know if this can be corrected or if it is in the Ooo code, but it is wrong ....


The NeoOffice Help defines these replacement rules for dashes:

A--B => A—B
(letter dash dash letter => letter em dash letter)
A --B => A –B
(letter space dash dash letter => letter space en dash letter)

If you don't agree with these rules, you may deactivate the "Replace dashes" routine in Options, activate "Use replacement table" & make your own rules on the Replace tab.
Back to top
View user's profile Send private message Visit poster's website
vicjoe
Captain


Joined: Oct 31, 2005
Posts: 56
Location: Victoria BC Canada

PostPosted: Wed Jul 25, 2007 3:33 pm    Post subject: thanks Reply with quote

As a former typesetter who lived through the change from $350,000 typesetting machines to networked Macintoshes in the late 80s, I can tell you the rules as set in Ooo and NeoO are incorrect to rectify the [space][two dashes][space] kludge brought in from the typewriter age when IBM computers were introduced. See the classic book "The Mac is Not a Typewriter" by Robin Williams for the straight goods. You see, it isn't a matter of optional preference, the Mac was designed from the ground up to be typographically accurate, and has only gotten better with Open Type. There is the historically established correct way to use one's powerful Mac or there is succumbing to kludges from the IBM/DOS days out of bad habit, not unlike ordering a fine marinated Biftek in a 5 star French restaurant then insulting the waiter with the gauche request for a bottle of catchup Embarassed You can do it, but it is wrong. The default in NeoOffice for replacing dashes is by the same token, wrong.

Thank you for the work-around, I'll give it a try.
Back to top
View user's profile Send private message
doctype
Oracle


Joined: Dec 08, 2005
Posts: 291
Location: Berlin, Germany

PostPosted: Wed Jul 25, 2007 3:53 pm    Post subject: Re: thanks Reply with quote

vicjoe wrote:
I can tell you the rules as set in Ooo and NeoO are incorrect to rectify the [space][two dashes][space] kludge brought in from the typewriter age when IBM computers were introduced.


Interesting historical perspective.

If you are sure, I think it would be best if you created a bug report at the OpenOffice.org bug tracking system. Start here:
http://qa.openoffice.org/issue_handling/pre_submission.html

That way, all versions of OpenOffice.org (including NeoOffice) may benefit.
Back to top
View user's profile Send private message Visit poster's website
mickeyinlalaland
Oracle


Joined: Feb 18, 2007
Posts: 239
Location: LaLaLand

PostPosted: Wed Jul 25, 2007 5:13 pm    Post subject: Reply with quote

I did find an interesting reference in the Help; select "Index" and search for
"dashes"

Quote:
Hyphen, dash
In order to enter longer dashes, you can find under Tools - AutoCorrect - Options the Replace dashes option (only on Windows systems). This option replaces one or two minus signs under certain conditions with an en-dash or an em-dash (see NeoOffice Help).


So this might be the answer as to why Tools>Autocorrect>Option has the "Edit" button greyed out when the "Replace dashes" entry is highlighted

the last part in parenthesis is a link to Options (for auto correct) and that has the information that doctype posted
Back to top
View user's profile Send private message
vicjoe
Captain


Joined: Oct 31, 2005
Posts: 56
Location: Victoria BC Canada

PostPosted: Wed Jul 25, 2007 7:09 pm    Post subject: re: interesting indeed Reply with quote

Oh man, even this board is now jinxed. I was still typing the above post, hit the return key to start a new paragraph and in a flash, without any intervening window telling me my post had been sent (which I didn't want to do anyway), my partial composition immediately flashed onto the screen, as well as this reply/edit window that I'm now writing in. I'm gonna give it a rest before commenting further, things are too weird right now. One hint: when I come back, I'm going to by typing with all real typographic symbols as HTML numeric entities, and see if this board recognizes them. Then I can more easily visually explain some of this stuff, but I won't necessarily know what others are seeing.

TAFN

Joe
Back to top
View user's profile Send private message
vicjoe
Captain


Joined: Oct 31, 2005
Posts: 56
Location: Victoria BC Canada

PostPosted: Wed Jul 25, 2007 7:14 pm    Post subject: interesting indeed (w/0 the Re:) Reply with quote

I guess the return key did a preview and I was flummoxed. Anyway, here's what I wrote:

mickeyinlalaland wrote
Quote:
I did find an interesting reference in the Help; select "Index" and search for
"dashes"

Quote:
Hyphen, dash
In order to enter longer dashes, you can find under Tools - AutoCorrect - Options the Replace dashes option (only on Windows systems). This option replaces one or two minus signs under certain conditions with an en-dash or an em-dash (see NeoOffice Help).


So this might be the answer as to why Tools>Autocorrect>Option has the "Edit" button greyed out when the "Replace dashes" entry is highlighted

the last part in parenthesis is a link to Options (for auto correct) and that has the information that doctype posted


Well, that is as clear as mud. The help file, not your post. What is meant by "Only on Windows systems"? If that is the case, then Mac, Linux and all other ports are poor relatives. So clicking on the "see NeoOffice Help" takes you to a table that explains what is being replaced by what, and the 2nd entry is where a space, two dashes/minuses and another space are incorrectly (by typographic convention) replaced with space-en[not em] dasj amd another space. Some may want to do that, but the point seems to be that this option cannot be edited in NeoOffice. Maybe the check marks that select the dashes replacement can be unchecked and some kind of macro devised?

Joe
Back to top
View user's profile Send private message
vicjoe
Captain


Joined: Oct 31, 2005
Posts: 56
Location: Victoria BC Canada

PostPosted: Wed Jul 25, 2007 7:25 pm    Post subject: Off topic - HTML typography here Reply with quote

I’m too burnt tonight to continue this “dashes” discussion, but for the sake of illustrating here in the forum what I’m talking about, you’ll notice—if this is working— real quotes, apostrophes and em dashes in this post. Does everybody see them, as opposed to the numeric entity code? I have this set up in a macro program.

I see them in my preview; just for fun, here’s some others:
degree sign: °
trademark: ™
ellipsis: …
registered serif: ®
Euro: €

Joe
Back to top
View user's profile Send private message
sardisson
Town Crier
Town Crier


Joined: Feb 01, 2004
Posts: 4588

PostPosted: Wed Jul 25, 2007 8:11 pm    Post subject: Reply with quote

Yep, the typographic glyphs look mighty fine in your last post Smile

Smokey

_________________
"[...] whether the duck drinks hot chocolate or coffee is irrelevant." -- ovvldc and sardisson in the NeoWiki
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Releases All times are GMT - 7 Hours
Goto page 1, 2, 3  Next
Page 1 of 3

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.03 Seconds