Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2022? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - NeoOffice/J 1.1x with second language aids
NeoOffice/J 1.1x with second language aids
 
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Testing
View previous topic :: View next topic  
Author Message
guest
Guest





PostPosted: Fri Sep 17, 2004 9:30 am    Post subject: NeoOffice/J 1.1x with second language aids Reply with quote

Have installed NeoOffice/J just now. Great! Looks much better than the previous version BUT how do I activate the language modules for a seconf language? I tried the dictionary list in the Application/Content/share/English/Dict but the dictionaries are already all included there. Still I can only access the English ones in the language setting under Tools/Options.

Sorry, if this is a stupid question and I am missing the obvious.
Back to top
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11932

PostPosted: Fri Sep 17, 2004 9:56 am    Post subject: Reply with quote

When you activate spellcheck, Neo/J uses only one dictionary. You can control which dictionary is loaded by setting "Default languages for documents" in Tools -> Options -> Language Settings -> Languages.

Patrick
Back to top
View user's profile Send private message Visit poster's website
Max_Barel
Oracle


Joined: May 31, 2003
Posts: 219
Location: French Alps

PostPosted: Fri Sep 17, 2004 10:11 am    Post subject: Or use styles Reply with quote

IIRC, the language setting of character style also activate the right dictionary.
To lazy to check it out right now.
Back to top
View user's profile Send private message Visit poster's website AIM Address
Guest
Guest





PostPosted: Fri Sep 17, 2004 10:36 am    Post subject: Reply with quote

[quote="pluby"]When you activate spellcheck, Neo/J uses only one dictionary. You can control which dictionary is loaded by setting "Default languages for documents" in Tools -> Options -> Language Settings -> Languages.

Patrick, cannot believe how quickly you respond! I have tried both your and Max's instructions - without success. If I switch to French (or German) it will not recognise words in these languages. Instead it asks me to add them to the standard dictionary. I will experiment a bit more.

Thanks for your help.
Back to top
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11932

PostPosted: Fri Sep 17, 2004 10:44 am    Post subject: Reply with quote

Guest wrote:
Patrick, cannot believe how quickly you respond! I have tried both your and Max's instructions - without success. If I switch to French (or German) it will not recognise words in these languages. Instead it asks me to add them to the standard dictionary. I will experiment a bit more.

Thanks for your help.


Are the French or German dictionaries enabled? By default, only dictionaries for the first language that you run Neo/J under are enabled. In other words, if you set your System Preferences to English and run Neo/J for the first time, ony the English dictionaries are enabled.

I know, this seems kind of stupid, but the underlying OOo code gets bogged down when all dictionaries are enabled and this restriction was implemented to work around that problem.

Anyway, to enable a dictionary, uncomment the applicable entry in the /Applications/NeoOfficeJ.app/Contents/share/dict/ooo/dictionary.lst file and restart Neo/J. Then you should be able to activate the uncommented dictionary.

Patrick
Back to top
View user's profile Send private message Visit poster's website
jakeOSX
Ninja
Ninja


Joined: Aug 12, 2003
Posts: 1373

PostPosted: Fri Sep 17, 2004 11:18 am    Post subject: Reply with quote

added to the wiki

-j
Back to top
View user's profile Send private message
Guest






PostPosted: Fri Sep 17, 2004 11:25 am    Post subject: Reply with quote

pluby wrote:
Anyway, to enable a dictionary, uncomment the applicable entry in the /Applications/NeoOfficeJ.app/Contents/share/dict/ooo/dictionary.lst file and restart Neo/J. Then you should be able to activate the uncommented dictionary.


Bingo! It works like a dream now. Thanks for that!
Back to top
Display posts from previous:   
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Testing All times are GMT - 7 Hours
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.03 Seconds