Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2017? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - Touch losing network connection to neomobile-test
Touch losing network connection to neomobile-test
 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> NeoOffice Mobile Testing
View previous topic :: View next topic  
Author Message
gantner
Red Pill


Joined: Jun 30, 2009
Posts: 9
Location: Louisville, KY

PostPosted: Wed Jul 01, 2009 9:37 pm    Post subject: Touch losing network connection to neomobile-test Reply with quote

In an attempt to recover my password I used the utility on the neomobile-test.neooffice.org site (https://neomobile-test.neooffice.org/users/forgotpassword) while using my iPod touch (beta OS: 3.1 (7c97d))

I entered my email and hit the 'send email' button. Three times in a row I was presented with a message stating: "Safari cannot open the page because the network connection was lost" - see attached photo.

I was getting the reset emails so the process was working but the consistent error message led me to believe that there was a problem.

this was over my home wi-fi network that I don't lose connections very often. No other web pages I have visited have given me errors tonight.

If there is anything else I can provide let me know.
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11882
Location: California, USA

PostPosted: Thu Jul 02, 2009 8:06 am    Post subject: Reply with quote

I can reproduce this in Safari when I set Safari to tell web server's that it is an iPod Touch 3.0. This does not happen when Safari is set to the default mode.

Tim,

Can you investigate this? I also found that once this happens, I get CakePHP's standard "page not found" page and the only way I can stop getting that page is to select Safari's Safari :: Reset Safari menu.

Patrick
Back to top
View user's profile Send private message Visit poster's website
narf
The Anomaly


Joined: Jan 21, 2007
Posts: 1075

PostPosted: Thu Jul 02, 2009 9:10 am    Post subject: Reply with quote

I have opened bug 3498 to track this problem. When there is status to report from the bug it will be posted here.

--fran
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11882
Location: California, USA

PostPosted: Thu Jul 02, 2009 4:28 pm    Post subject: Reply with quote

I think that I have fixed bug 3498. The bug was in our webserver code and our servers now have my fix. Can you tell us if the bug is fixed for you?

Tim,

Now that this CakePHP infinite recursion bug is fixed, I noticed that when you click on the link in the e-mail that is sent, the "webLayout" layout is used instead of the "defaultMobile" layout even though my user agent is still set to an iPod Touch. Is this something that you can take a look at?

Patrick
Back to top
View user's profile Send private message Visit poster's website
TimT
Agent


Joined: Feb 24, 2009
Posts: 15

PostPosted: Thu Jul 02, 2009 7:33 pm    Post subject: Reply with quote

Yea I'll take a look at this. I'll post back when I find a fix.
Back to top
View user's profile Send private message Visit poster's website
gantner
Red Pill


Joined: Jun 30, 2009
Posts: 9
Location: Louisville, KY

PostPosted: Fri Aug 28, 2009 4:40 pm    Post subject: Confirmation of fix Reply with quote

The password reset no longer triggers a 'network time out' as it had before on my ipod. The problem is resolved from my end. Thank you and sorry for the long delay in confirming the fix from my submission.

Just as a matter of usability: While the page offers a green banner that the email was indeed sent, the user is required to either click the browser 'Back' button or select 'Cancel' to return to the login page. kinda confusing.
Back to top
View user's profile Send private message Visit poster's website
TimT
Agent


Joined: Feb 24, 2009
Posts: 15

PostPosted: Wed Sep 09, 2009 9:17 pm    Post subject: Reply with quote

Quote:

Just as a matter of usability: While the page offers a green banner that the email was indeed sent, the user is required to either click the browser 'Back' button or select 'Cancel' to return to the login page. kinda confusing.


Is this on the page where you enter your email, or on the page after you click the link from the email? Should we remove the input and cancel link?
Back to top
View user's profile Send private message Visit poster's website
gantner
Red Pill


Joined: Jun 30, 2009
Posts: 9
Location: Louisville, KY

PostPosted: Thu Sep 10, 2009 3:58 am    Post subject: Just after submitting my email Reply with quote

After I submit my email to have my password reset I am presented with a green banner that tells me the email was sent successfully (see attached image). I guess I was expecting to see a button that directed me to a login page but the only two buttons are "Cancel' or "Send Email" - neither of which i want to do.

Of course the menu above is there to choose from (not in screenshot) but a new button would also confirm that the password process is moving along successfully.

Just my thoughts about it. Let me know if I can provide anything else.
Back to top
View user's profile Send private message Visit poster's website
TimT
Agent


Joined: Feb 24, 2009
Posts: 15

PostPosted: Tue Sep 22, 2009 8:54 pm    Post subject: Reply with quote

Yea, I think having the input and the submit button could be confusing. I'll remove those and replace it with instructions. See attached image. Does this look better?
Back to top
View user's profile Send private message Visit poster's website
gantner
Red Pill


Joined: Jun 30, 2009
Posts: 9
Location: Louisville, KY

PostPosted: Wed Sep 23, 2009 10:59 am    Post subject: Much Clearer Reply with quote

Your revised page is much clearer to me as a user than the current version. It tells me that the process is complete, successful and provides the next steps. Thanks for addressing this.

Matt
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11882
Location: California, USA

PostPosted: Thu Sep 24, 2009 8:17 pm    Post subject: Reply with quote

FYI. I have added TimT's changes (as well as the changes for other bugs that he has fixed) on our test servers. If Fran finds no breakage while testing these changes over the next few days, we will then add the changes to the NeoOffice Mobile official website.

Patrick
Back to top
View user's profile Send private message Visit poster's website
narf
The Anomaly


Joined: Jan 21, 2007
Posts: 1075

PostPosted: Tue Sep 29, 2009 7:29 am    Post subject: Reply with quote

FYI: The changes to the password reset window have now been added to NeoOffice Mobile. Can you take a look at the password reset window and let us know if you see the revised page?

--fran
Back to top
View user's profile Send private message
gantner
Red Pill


Joined: Jun 30, 2009
Posts: 9
Location: Louisville, KY

PostPosted: Tue Sep 29, 2009 7:53 am    Post subject: Can't confirm changes Reply with quote

When I connect to neomobile-test.neooffice.org (https or http) I am immediately presented with a authentication dialog box before any page content is rendered. Embarrassingly, and what prompted this thread, I have forgotten my USER ID and PASSWORD for the site but now there is no option for me to recover it.

I connected to neomobile-test.neooffice.org from within Neooffice (mac) 3.0 patch 7 and also using Sarfari (mac) 4.3 as well as Safari 4.3 with user-agent Safari Mobile 3.0 iPod Touch. None presented me with any way to recover my password.

I am guessing that the option has been removed through revision to the site but please inform me if I should now go about recovery in a new manner - it is not obvious to me at the moment.
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11882
Location: California, USA

PostPosted: Tue Sep 29, 2009 8:10 am    Post subject: Re: Can't confirm changes Reply with quote

gantner wrote:
When I connect to neomobile-test.neooffice.org (https or http) I am immediately presented with a authentication dialog box before any page content is rendered. Embarrassingly, and what prompted this thread, I have forgotten my USER ID and PASSWORD for the site but now there is no option for me to recover it.


The change is in the production NeoOffice Mobile environment at the following URL:

http://neomobile.neooffice.org/

As described in this post, the Preview phase ended on 15 September 2009 and NeoOffice Mobile went "live" on that same date so we repurposed our test environment for internal testing before pushing changes into our production environment.

Patrick
Back to top
View user's profile Send private message Visit poster's website
gantner
Red Pill


Joined: Jun 30, 2009
Posts: 9
Location: Louisville, KY

PostPosted: Tue Sep 29, 2009 8:18 am    Post subject: Looks good Reply with quote

Sorry. My second son was born 9/11 and my brain has turned to mush with lack of sleep. Confused

The changes on the site appeared as shown in the previous posts. I think the confirmation and next steps are much clearer to the User now. Thank you.
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> NeoOffice Mobile Testing All times are GMT - 7 Hours
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.03 Seconds