Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2017? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - Removing Java from windows, menus, and printing
Removing Java from windows, menus, and printing
 
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Testing
View previous topic :: View next topic  
Author Message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11914
Location: California, USA

PostPosted: Tue May 22, 2012 1:29 pm    Post subject: Re: screen artifacts Reply with quote

revsmitty wrote:
I do have a screen shot it that would help you see what I saw.


Yes. Please attach the screen snapshot. Hopefully, it will help me narrow down which of the native drawing operations might be causing what see.

Patrick
Back to top
View user's profile Send private message Visit poster's website
revsmitty
Keymaker


Joined: May 15, 2005
Posts: 94
Location: Iowa, USA

PostPosted: Tue May 22, 2012 1:47 pm    Post subject: Reply with quote

Here is the screen shot I took.
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11914
Location: California, USA

PostPosted: Tue May 22, 2012 2:13 pm    Post subject: Reply with quote

So I think I know what is occurring although I cannot reproduce the problem. when you scroll to see the hidden portion of the right column, the hidden part is copied from an offscreen image where the text was previously drawn to. The problem appears to be that the offscreen image is being drawn 1 pixel to far right and 1 pixel too far down.

I will look at my native offscreen image copying code to see if there is any code that might be miscalculating the window coordinates to draw to.

Patrick
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11914
Location: California, USA

PostPosted: Wed May 23, 2012 10:12 pm    Post subject: Reply with quote

I have made the following changes in the following test patch:

1. I have made some small tweaks the offscreen image drawing code in an attempt to fix the slightly offset drawing that revsmitty reported in his last few posts. I am hoping that this test patch will either fix the problem or increase the frequency of the problem. If either case happens, please let us know.

2. I have upgraded our patch installer to use Apple's newer "flat package" format. This change is necessary in order to support code signing of the installers in our upcoming Beta so that Mac OS X 10.8 Mountain Lion's new Gatekeeper feature will allow our installer to run by default. If the test patch fails to install for any reason, please let us know.

Intel:
http://sally.neooffice.org/test/NeoOffice-3.2.1-Patch-5-Test-5-Intel.dmg

Patrick
Back to top
View user's profile Send private message Visit poster's website
revsmitty
Keymaker


Joined: May 15, 2005
Posts: 94
Location: Iowa, USA

PostPosted: Thu May 24, 2012 7:58 am    Post subject: Reply with quote

P5T5 installed fine on my 10.6.8 MacMini. It did not resolve the screen drawing issue. It does appear to me that the offscreen image is now being drawn correctly vertically but is still 1 pixel off horizontally.

I will attach a screen shot. I also have a multiple page LoremIpsum document that I can send since it seems to appear more frequently when I am pasting into it with things like different margins, indents, and hanging indents.
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11914
Location: California, USA

PostPosted: Thu May 24, 2012 8:09 am    Post subject: Reply with quote

revsmitty wrote:
P5T5 installed fine on my 10.6.8 MacMini. It did not resolve the screen drawing issue. It does appear to me that the offscreen image is now being drawn correctly vertically but is still 1 pixel off horizontally.


That is good news to hear that the vertical portion of the problem is fixed. For me, that confirms that I have found the location in the code that is causing the bug.

revsmitty wrote:
I will attach a screen shot. I also have a multiple page LoremIpsum document that I can send since it seems to appear more frequently when I am pasting into it with things like different margins, indents, and hanging indents.


I have been using the attached 2 column document filled with "lorem ipsum" text as well. What I am interested to know is you have any specific steps that I can use to emulate pasting different margins, indents, and hanging indents. I admit that I don't fuss with margins so if you have some common steps that you have done that occasionally trigger this bug, that might help me locate the cause of the remaining horizontal shifting.

Patrick
Back to top
View user's profile Send private message Visit poster's website
revsmitty
Keymaker


Joined: May 15, 2005
Posts: 94
Location: Iowa, USA

PostPosted: Thu May 24, 2012 1:13 pm    Post subject: Reply with quote

Patrick, Using your columns document I was able to cause it to happen 3 times in a row by doing the following.

With just the left column and only 1/2 of the right column showing

1) Copy the Nam imperdiet paragraph and paste it 3 times in the first column on the second page before the Vestibulum paragraph.

2)Without scrolling up or down the page start with the last of the 3 paragraphs you pasted and make it a hanging indents by sliding the left margin marker (the house shaped one in the formatting ruler) the the right to about 1" then slide the first line margin marker back to the left and create about a 1/2" hanging indent. Repeat this for each of the other two paragraphs again without doing any vertical scrolling.

Now if you scroll to the right hand column You should see the issue show up in the Nulla pulvinar paragraph

The multiple setting/changing of paragraph formatting seems to be the main trigger because it causes the screen redraws and the resultant offset when you scroll to the off screen part of the page.
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11914
Location: California, USA

PostPosted: Thu May 24, 2012 3:02 pm    Post subject: Reply with quote

Thank you very much for the steps. I can now easily reproduce the horizontal shifting.

I will post again when I have a test patch with fix for this bug.

Patrick
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11914
Location: California, USA

PostPosted: Thu May 24, 2012 8:59 pm    Post subject: Reply with quote

I think that I have fixed the horizontal shifting bug described in revsmitty's last post.

Can you install the following test patch and tell us if the horizontal shifting bug is fixed for you?:

Intel:
http://sally.neooffice.org/test/NeoOffice-3.2.1-Patch-5-Test-6-Intel.dmg

Patrick
Back to top
View user's profile Send private message Visit poster's website
revsmitty
Keymaker


Joined: May 15, 2005
Posts: 94
Location: Iowa, USA

PostPosted: Fri May 25, 2012 8:05 am    Post subject: Reply with quote

P5T6 seems to solve the issue. Nicely done Patrick!
Back to top
View user's profile Send private message
sardisson
Town Crier
Town Crier


Joined: Feb 01, 2004
Posts: 4588

PostPosted: Sun May 27, 2012 11:02 pm    Post subject: Reply with quote

I haven't had much time to play with the latest test patches, but I've uncovered two bugs with the recent changes Sad

First, I can no longer use the keyboard to close the "You have unsaved changes; are you sure you want to quit" dialog; STR:

1) Open Neo
2) Open a new document, type any letter
3) Cmd-Q
4) Try to trigger any of the buttons with the keyboard (Return, Esc, D/Cmd-D)

This still works fine in the regular Patch-5, and I'm pretty sure it worked correctly after the prior round (pre-Patch-5) of deJavafication. 10.5.8/Intel with Patch-5-Test-6 here; I checked both my regular and testing accounts.

Second, it's no longer possible (I assume with the switch to the new installer package type) to re-install the regular patch over top of the corresponding test patch (for instance, in order to verify something works normally in the regular patch). Installer.app claims "You cannot install NeoOffice 3.2.1 Patch 5 on this volume. A newer version of this software already exists on this volume."

With some help from Uncle Google and Uncle man-page, I discovered that
Code:
sudo pkgutil --forget org.neooffice.NeoOffice_patch.pkg
will make Installer.app allow me to reinstall the regular patch over the test one, so it's not the end of the world for us testing-users, but I remember that some years ago you had put in substantial effort to make it "just work" Sad

I hope that you have a good Memorial Day—and that you don't spend it debugging these Wink

Smokey

_________________
"[...] whether the duck drinks hot chocolate or coffee is irrelevant." -- ovvldc and sardisson in the NeoWiki
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11914
Location: California, USA

PostPosted: Sun May 27, 2012 11:28 pm    Post subject: Reply with quote

sardisson wrote:
First, I can no longer use the keyboard to close the "You have unsaved changes; are you sure you want to quit" dialog; STR:

1) Open Neo
2) Open a new document, type any letter
3) Cmd-Q
4) Try to trigger any of the buttons with the keyboard (Return, Esc, D/Cmd-D)


I can reproduce this as well so I will investigate what is broken in my new code. I also found that I had accidentally disabled full screen mode on Mac OS X 10.7 and 10.8 so I will put that fix and a few other small fixes in the next test patch.

sardisson wrote:
Second, it's no longer possible (I assume with the switch to the new installer package type) to re-install the regular patch over top of the corresponding test patch (for instance, in order to verify something works normally in the regular patch). Installer.app claims "You cannot install NeoOffice 3.2.1 Patch 5 on this volume. A newer version of this software already exists on this volume."


I ran into this same issue for the first time yesterday so I suspect that when I converted to Apple's new "flat package" format, I am missing some option that says the package is upgradable and, as a result, our volume check script in the installer doesn't even get run. Instead, the installer automatically marks the volume that you previously installed the patch to as "not available."

For now, using the
Code:
sudo pkgutil --forget org.neooffice.NeoOffice_patch.pkg
that you found is the workaround that I use. But I will research the Apple flat package XML documentation to see if I can find any configuration option that will restore the old behavior.

Patrick
Back to top
View user's profile Send private message Visit poster's website
amayze
The Merovingian


Joined: Oct 24, 2005
Posts: 561
Location: Edinburgh, Scotland

PostPosted: Tue May 29, 2012 7:59 am    Post subject: Reply with quote

I just installed the latest Patch 5 test 6 and have found a couple of issues in Base.

First the Sun Report Builder section labels to the left of a report being edited are all black - vanilla 3.2.1 and P5T6 screen shots attached.

Secondly, after following through the New Report Wizard, at the last stage selecting to modify the report displays the report in edit mode, but selecting to run the report immediately shows a blank window and then crashes NeoOffice, crash report attached.

Andy
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11914
Location: California, USA

PostPosted: Tue May 29, 2012 8:11 am    Post subject: Reply with quote

amayze wrote:
First the Sun Report Builder section labels to the left of a report being edited are all black - vanilla 3.2.1 and P5T6 screen shots attached.

Secondly, after following through the New Report Wizard, at the last stage selecting to modify the report displays the report in edit mode, but selecting to run the report immediately shows a blank window and then crashes NeoOffice, crash report attached.


I can reproduce both of these bugs on my machines. Also, I can reproduce the crashing bug by creating a new table in an empty database with the "create new table" wizard.

I just finished fixing the bugs that reported in Smokey's last post so I will investigate these 2 bugs immediately.

Patrick
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11914
Location: California, USA

PostPosted: Tue May 29, 2012 5:46 pm    Post subject: Reply with quote

I think that I have fixed the following bugs reported in sardisson's and amayze's last posts:

1. All key entry in the save/discard dialog is ignored

2. Installing test patch's that use Apple's new "flat package" format prevent reinstallation of current official patch

3. Crashing when pressing the "Finished" button in the Base wizards

4. Gradients in Base's report builder are black

Also, I fixed the following small bugs that I found while using the last test patch:

1. Full screen mode in Mac OS X 10.7 and 10.8 was disabled

2. Mouse move events behaved as drag events after pressing a window's zoom or full scree buttons

3. Pressing the zoom button on a document that was zoomed to fill the screen when it was last open caused the window to show only the titlebar

Can you install the following test patch and tell us all of the bugs that you reported are fixed for you?:

Intel:
http://sally.neooffice.org/test/NeoOffice-3.2.1-Patch-5-Test-7-Intel.dmg

Patrick
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Testing All times are GMT - 7 Hours
Goto page Previous  1, 2, 3 ... 5, 6, 7 ... 10, 11, 12  Next
Page 6 of 12

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.07 Seconds