Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2017? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - Disappearing images
Disappearing images
 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> NeoOffice Beta Releases
View previous topic :: View next topic  
Author Message
amayze
The Merovingian


Joined: Oct 24, 2005
Posts: 561
Location: Edinburgh, Scotland

PostPosted: Tue Jun 26, 2012 4:10 am    Post subject: Disappearing images Reply with quote

Found another one!

Open a new writer document.
Select Insert->Picture->From File
Click and hold on the picture until the pointer changes from crossed arrows to a clenched fist.
Release the mouse button.
The picture disappears.

Cmd-Z will bring it back and moving it a large amount works correctly.
I've tested this with .png and .gif images and the same thing happens.

I attach a screen shot of the rather odd entry in the File menu for Undo after the bug has happened.

Andy
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11882
Location: California, USA

PostPosted: Tue Jun 26, 2012 7:44 am    Post subject: Reply with quote

This bug also occurs in NeoOffice 3.2.1 so this bug has apparently been in NeoOffice for quite a while. It does not occur in my Go-oo 3.1.1.1 build so it is definitely our bug.

I suspect that the cause is somewhere in our drag and drop code as based on the fact that the cursor changes to the closed hand cursor and after the image is deleted, the undo menu is set to "Move".

I will investigate this bug after I work through the hanging bug that you found and this Retina display text blurriness issue.

Patrick
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11882
Location: California, USA

PostPosted: Wed Jun 27, 2012 9:42 pm    Post subject: Reply with quote

I think that I have fixed this bug in the following test patch.

Can you install the test patch and tell us if the bug is fixed for you?:

Intel:
http://sally.neooffice.org/test/NeoOffice-3.3_Beta-Patch-0-Test-3-Intel.dmg

Patrick
Back to top
View user's profile Send private message Visit poster's website
amayze
The Merovingian


Joined: Oct 24, 2005
Posts: 561
Location: Edinburgh, Scotland

PostPosted: Thu Jun 28, 2012 2:57 am    Post subject: Reply with quote

Installed Patch 0 Test 3.

The image no longer disappears. However all is not quite well.

If I now click on an image and then wait for longer than the double click time, then click again, the Picture dialogue pops up. I don't think this is the correct behaviour, it should only open on a deliberate double click.

If I click and drag immediately only guides are shown moving and the pointer is crossed arrows.

If I click and hold then drag the pointer changes to the hand, but I get no feedback until I let go of the mouse button when the images jumps to its new position. I think click-hold-drag is supposed to show the actual image moving during the drag.

In the middle of one of my test moves NeoOffice decided to autosave my Untitled document, the progress bar got to about 90%, the SPoD appeared and after a few seconds NeoOffice crashed. Crash log attached.

Andy.
Back to top
View user's profile Send private message Visit poster's website
amayze
The Merovingian


Joined: Oct 24, 2005
Posts: 561
Location: Edinburgh, Scotland

PostPosted: Thu Jun 28, 2012 3:03 am    Post subject: Reply with quote

Just spotted some further oddness.

After a click-hold-drag the Edit menu has an item Undo: Move: picture

After a click-drag the Edit menu has Undo:Change style: graphics1

Screen shots attached.

Andy
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11882
Location: California, USA

PostPosted: Thu Jun 28, 2012 9:32 am    Post subject: Reply with quote

amayze wrote:
If I click and hold then drag the pointer changes to the hand, but I get no feedback until I let go of the mouse button when the images jumps to its new position. I think click-hold-drag is supposed to show the actual image moving during the drag.


This is normal behavior in OpenOffice.org 3.1.1 (which NeoOffice is based on) when you click and hold and then drag a picture. Clicking and holding before dragging drags without any movement of the image until you release the mouse. You will only see the image move while you drag if you click and immediately drag.

amayze wrote:
After a click-hold-drag the Edit menu has an item Undo: Move: picture

After a click-drag the Edit menu has Undo:Change style: graphics1


This is also normal behavior in OpenOffice.org 3.1.1. Click, hold, and drag and click drag result in different actions so you get different names for the undo menu.

I will investigate what is causing the crash and the appearance of the Picture dialogue. I will post again when I have some news to report

Patrick
Back to top
View user's profile Send private message Visit poster's website
amayze
The Merovingian


Joined: Oct 24, 2005
Posts: 561
Location: Edinburgh, Scotland

PostPosted: Thu Jun 28, 2012 1:07 pm    Post subject: Reply with quote

pluby wrote:
amayze wrote:
If I click and hold then drag the pointer changes to the hand, but I get no feedback until I let go of the mouse button when the images jumps to its new position. I think click-hold-drag is supposed to show the actual image moving during the drag.


This is normal behavior in OpenOffice.org 3.1.1 (which NeoOffice is based on) when you click and hold and then drag a picture. Clicking and holding before dragging drags without any movement of the image until you release the mouse. You will only see the image move while you drag if you click and immediately drag.

Ok. Obviously I was mistaking this for how some other application works. I could've sworn click-hold-drag showed the image moving, but hey that would be far too sensible!! I now notice (in NeoOffice and OO.o 3.3) that click-hold-drag doesn't even move the image the same distance as you move the mouse! But obviously this is a feature of OpenOffice.org and not an issue for us here.

Andy.
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11882
Location: California, USA

PostPosted: Thu Jun 28, 2012 2:16 pm    Post subject: Reply with quote

I found the cause for the Picture dialog appearing when there has been no double click and it was due to a stupid error on my part. I was using Unix time for event timestamps and those are too large to convert to milliseconds and still fit in the data type that OpenOffice.org allocates for event timestamps.

So, in the following test patch I have switched to using the time elapsed since last system boot for event timestamps.

Can you install the test patch and tell us if Picture dialog appearing without a double click works for you?:

Intel:
http://sally.neooffice.org/test/NeoOffice-3.3_Beta-Patch-0-Test-4-Intel.dmg

Patrick
Back to top
View user's profile Send private message Visit poster's website
amayze
The Merovingian


Joined: Oct 24, 2005
Posts: 561
Location: Edinburgh, Scotland

PostPosted: Fri Jun 29, 2012 2:18 am    Post subject: Reply with quote

Patch 0 Test 4 fixes the Picture dialogue double click bug for me.

Thanks,

Andy
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11882
Location: California, USA

PostPosted: Fri Jul 13, 2012 10:02 am    Post subject: Reply with quote

FYI. I have included the fix this bug in NeoOffice 3.3 Beta Patch 1. You can download the patch from the NeoOffice 3.3 Beta patch download page.

I have also included the fix in NeoOffice 3.2.1 Patch 7. You can download the patch from the NeoOffice 3.2.1 patch download page.

Patrick
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> NeoOffice Beta Releases All times are GMT - 7 Hours
Page 1 of 1

 
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.03 Seconds