Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2017? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - spell check dictionary
spell check dictionary
 
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Releases
View previous topic :: View next topic  
Author Message
berrima
Agent


Joined: May 02, 2005
Posts: 10

PostPosted: Wed May 04, 2005 3:13 pm    Post subject: spell check dictionary Reply with quote

can anyone explain why the spell check dictionary reverts to us english despite having defaul set to australian english?

thank you
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11853
Location: California, USA

PostPosted: Wed May 04, 2005 3:52 pm    Post subject: Reply with quote

The whole spellcheck options is, IMHO, very obtuse. To get this to work for English other than U.S. English, you need to do the following:

1. For new documents, setting the default document language to Australian English in Tools -> Options -> Language Settings -> Languages is enough.

2. For existing documents, you need to change the document's language setting by opening the document and then opening Tools -> Options -> Language Settings -> Languages. Change the default language to Australian English and check the "For the current document only" box.

Hope that helps.

Pattrick
Back to top
View user's profile Send private message Visit poster's website
berrima
Agent


Joined: May 02, 2005
Posts: 10

PostPosted: Wed May 04, 2005 11:08 pm    Post subject: Reply with quote

have tried suggestion and various permutations to set spell check dictionary to something other than us english, and it stil reverts when we do a spell check for an exiting document.

will return to nisus for now.

thank you
Back to top
View user's profile Send private message
JKT
The Anomaly
(earlier version)


Joined: Sep 18, 2003
Posts: 434
Location: London, UK

PostPosted: Thu May 05, 2005 7:03 am    Post subject: Reply with quote

Was Australian English your default system language for OS X when you installed NeoOffice/J? If not, read this link to find out why your dictionary may not be working.
_________________
PBG4, 1.5GHz, SuperDrive, 1GB RAM, 128MB VRAM, 5400rpm 80GB HD, MacOS X 10.4.5

Please visit The Land Gallery at http://www.thelandgallery.com for nature-inspired British Fine Art
Back to top
View user's profile Send private message Visit poster's website
berrima
Agent


Joined: May 02, 2005
Posts: 10

PostPosted: Thu May 05, 2005 3:20 pm    Post subject: Reply with quote

yes, australian english is our panther default.

seems neoj accepts a language change when setting up a new doc but if saved and reopened it reverts to us english.

sure it will be sorted out, and that neoj may eventually become a standard for osx with full apple support.

thank you for your reply.[/i]
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11853
Location: California, USA

PostPosted: Thu May 05, 2005 3:31 pm    Post subject: Reply with quote

berrima wrote:
seems neoj accepts a language change when setting up a new doc but if saved and reopened it reverts to us english.


This happens because when you save a document, OOo saves the default language in the document file. So, when you open up a document that has a different language setting, the language setting for that document will be used when you are editing that document.

Unfortunately, to correct this, you need to open the document, then open Tools -> Options -> Language Settings -> Languages, change the default language to Australian English and check the "For the current document only" box, close the dialog, and save the document.

You need to do this for each existing document that you open.

Patrick
Back to top
View user's profile Send private message Visit poster's website
berrima
Agent


Joined: May 02, 2005
Posts: 10

PostPosted: Thu May 05, 2005 5:15 pm    Post subject: Reply with quote

thank you partick, have tried that with different languages and when we open spellckeck it is still set to us english.

then, when we select another language in the spell check dialogue it reverts on the next word - does it have anything to do with what save file format is used?

your time and courtesy in attempting to resolve this matter is appreciated.
Back to top
View user's profile Send private message
Luke
Captain


Joined: Sep 08, 2003
Posts: 63
Location: Teesside, UK

PostPosted: Fri May 06, 2005 1:15 am    Post subject: Reply with quote

Berrima wrote

Quote:
then, when we select another language in the spell check dialogue it reverts on the next word - does it have anything to do with what save file format is used?


I have found it necessary to select the text of interest (probably select all in your case) and format/character to force it to be the desired language. Then save. This behaviour is identical to that in MS Word, and is probably an inevitable consequence of the feature of allowing multiple languages in a document. If you have a lot of these to do you could record the steps as a macro.

Luke
Back to top
View user's profile Send private message
Fredrik Stendahl
Guest





PostPosted: Fri May 06, 2005 5:35 am    Post subject: Reply with quote

In the definition of paragraph styles there is an option to set the language for the style. It is in the pane where you chose font for the paragraph.

This is what the Help says on the topic:

"Language

Sets the language that the spellchecker uses for the selected text of the text that you type. Available language modules have a check mark in front of them."

I suppose that the default template for new Writer documents should have styles with the 'proper' language setting. If a new document has another language the default template has to replaced with one that has the correct language setting for paragraph styles.

For me this was automagically Swedish, as I have installed NeoJ on a system with Swedish as primary language.

hth

F
Back to top
berrima
Agent


Joined: May 02, 2005
Posts: 10

PostPosted: Sun May 08, 2005 3:19 pm    Post subject: Reply with quote

thank you for the suggestions.

good fortune
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Releases All times are GMT - 7 Hours
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.08 Seconds