Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2022? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - 1.1.0 / X11 First impressions, Windowing
1.1.0 / X11 First impressions, Windowing
 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> OpenOffice.org X11 Testing
View previous topic :: View next topic  
Author Message
Guest






PostPosted: Thu Oct 16, 2003 6:16 pm    Post subject: 1.1.0 / X11 First impressions, Windowing Reply with quote

OK, here's the details,

TiPowerbook with 867Mhz G4, 512Mb Ram, 40Gb HD

OS 10.2.8 take 2, Apple's X11 beta 3

I've opened two writer windows, different files. The windows can be dragged around the desktop, the jellybeans work, I can bring either window to the front by clicking it, the menus on both windows work. I'm not seeing the window creep bug that you someimes see with X11. In short, the windowing seems to be fine.

Start up time was fast!

The xterm showed an error when I opened the first file - apparently a font issue. The file looks OK on screen to me. Here's the error:

sh: /usr/bin/lpc: No such file or directory
_XF86BigfontQueryFont: could not attach shm segment

Now I'll get into these files and start editing and saving them.

Cheers, Phil
Back to top
Guest






PostPosted: Thu Oct 16, 2003 10:14 pm    Post subject: Writer files Reply with quote

OK, I've got a .sxw document here which includes tables, bulleted lists, headers, page numbers in the footers, hyperlinked web addresses and e-mail addresses, logos, and emphasis fonts (bold, italics, etc).

Here's what I tried.

Edited text and saved as .sxw - No problems

Edited an equation, added to the text and saved the equation as .sxm - No problems

Saved as Word 97/2000/XP (.doc) - No problems. I had the .doc and .sxw windows side by side and scrolled the entire document. There were no differences in spacing, fonts, bulleting or table format.

Clicked on hyperlinks - The security dialogue box came up asking if I wanted to proceed. When I clicked Yes, I got "No corresponding external application could be found for the given file type. Please check the OpenOffice.Org settings (OK)"

Could be that the program can't see browsers or e-mail apps outside the X11 world. I had Safari running at the time, so no problems with web access. One trivial difference between the .sxw version and the .doc version - after I'd clicked on the hyperlink, the .doc hyperlink turned red, while the .sxw hyperlink stayed blue. I'm sure that's the kind of issue you're worried about at the moment.

Export as PDF - No problems! OOo now officially contains functionality I need which is lacking in M$ Word. (as well as being more efficient, free of macro viruses and 100% cheaper Smile )

Next up, I'll try to pull in a Word document, then I'll start looking at spreadsheets.

Cheers, Phil
Back to top
Guest






PostPosted: Thu Oct 16, 2003 10:48 pm    Post subject: spreadsheets, word processing Reply with quote

Next bit!

The Word document came in OK. Once again, this was a document that included logos, tables, bulleted lists, headers & footers. I tried a couple of more things: Red text and yellow highlighting from the buttons in the tool bar both worked. I was able to save as a Word document with the red text & highlighting intact.

I've opened a .sxc spreadsheet. It seems to be identical to the file on the PC (originally created with OOo1.1.0 on the PC). The most complex function on this spreadsheet is SUM: so someone else with real spreadsheets had better get testing.

Save as .sxc works.

I've just exported it to Excel 97/2000/XP, No problems. One thing I noticed with both the word processing files and the spreadsheet is that export to the M$ format is phenomenally fast.

I've just exported to PDF from the .sxc file. The export was successful, but the dialogue box was affected by the X11 window creep bug - the first window I've seen that happen to in the program.

OK, time for an early weekend, but I'll have a go at (gulp) printing on monday.

Cheers, Phil
Back to top
fa
The Architect
The Architect


Joined: May 27, 2003
Posts: 88

PostPosted: Sat Oct 18, 2003 8:27 am    Post subject: Reply with quote

Hi,

I think the hyperlink issue is because we haven't done all the OS X install magic with 1.1 builds yet since they aren't final. If you'd like to fix this, choose Tools->Options, click the External Programs option, and then replace all the HTTP, HTTPS, FTP, and MAIL boxes with "/usr/bin/open" (no quotes).

Dan
Back to top
View user's profile Send private message
Guest






PostPosted: Tue Oct 21, 2003 7:44 pm    Post subject: more bits, presentation manager Reply with quote

Hi all, some more bits,

I'm consistantly finding that saving files to M$ Office format and loading from M$ Office format is actually faster than saving or loading native OOo files. This is certainly not true with OOo1.1.0 on a Wintel machine.

I've been collaborating on a file with a co-worker who uses M$ Office. They are able to open files that I saved as .doc, there are no format issues that I can see, and they are able to see the Track Changes details that I created in OOo. For any normal work environment, this is perhaps the most critical improvement for 1.1.0 over 1.0.3, and I'm glad to see that it works on Mac.

I opened a PowerPoint file, and I was able to edit it. It contained fonts which I do not have on my computer, and they were rendered with reasonable anti-aliasing, but too large - some text was bumped off the bottom of the slide.

The second slide contained bitmap images with text and arrows over the top. All of these rendered correctly in Drawing view.

When I went to slideshow mode, the top menu bar was still present (I know this may be impossible to fix until a native Aqua version is available), and the Dock was still present (can this be covered up in the X11 version?). I was able to advance with the right or down arrow keys, while the up or left arrow keys took the slideshow back one slide. The (single button!) mouse advanced the slide show, while Command-click took the slide show back one slide. The pictures with text and arrows rendered correctly in the slide show.

To summarise all these posts, OOo1.1.0 is currently more useable than the packaged 1.0.3, because of all the improvements in the actual program. I'm happy to keep using it on the Mac with startup from the command line until a packaged version becomes available.

I installed the program under my user directory. For those who aren't used to the command line, here's my startup:

1) Start Apple's X11.

2) Using the Xterm which opens by default, type

cd OpenOffice1.1.0/program

You can get a couple of letters into this address and hit the Tab key to complete a directory. Capitalisation matters.

3) type

sh soffice

and an Aquafied window will open with the OOo window inside. Start up takes about 10-15 seconds on my midrange Powerbook.

As long as you keep one OOo window open, you can always open more windows from the File menu and they open in about 1-3 seconds.

Cheers, Phil
Back to top
Guest






PostPosted: Thu Oct 23, 2003 7:22 pm    Post subject: Printing Reply with quote

Hi all,

Much to my surprise, printing worked first time! I opened a M$ Word document and told it to print without saving as a .sxw first. In the print dialogue box, I left the printer as 'Generic', but told it to print A4 instead of US Letter. When I walked around to the (remote, networked, Departmental) printer, it said 'Tray not selected'. I pushed the A4 tray button and the file printed.

This was a 10 page document, with colour graphs and a couple of colour headings, being printed on a B&W printer. There was a mix of Portrait and Landscape pages, which were all printed with the correct orientation. The margins are correct on both orientations. The graphs were rendered very well into greyscale. The colour headings printed as dark grey and look black to a casual reader. The text font was a standard one on my computer, and printed correctly - even the large font sizes. Track Changes was turned on in the document, and the deleted characters printed as strikethrough characters. I can't remember if the default behaviour in Track Changes is to print deleted text or not.

Has anyone else printed from 1.1.0 / X11? There must be a lot of print settings that this file didn't test.

Cheers, Phil
Back to top
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> OpenOffice.org X11 Testing All times are GMT - 7 Hours
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.03 Seconds