Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2017? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - Getting 2.0.2 rc 4 to print
Getting 2.0.2 rc 4 to print
 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> OpenOffice.org MacOS X X11 Support
View previous topic :: View next topic  
Author Message
LJHeal
Red Pill


Joined: Mar 14, 2006
Posts: 7

PostPosted: Tue Mar 14, 2006 2:41 am    Post subject: 2.0.2rc4 - to print (or not to print) Reply with quote

Well, I suppose before I announce the workaround I should try to print something, not just take spadmin at its word...yep, blank page out.

These builds (rc3, rc4 tried) downloaded from ftp://ooopackages.good-day.net/pub just did not want to create a printer-type, Generic or no, on this 10.3.9 system.

Tried fooling it by pointing into OO2.0, no luck. Tried copying out the share/psprint directory (and the spadmin & spadmin.bin tools) from OO2.0 into OO2.0.2rc4, luck.

Then the application still demanded restart before things propagated; it was saying yesIdo noIdon't for a while.

It's sad to be in user land when you used to be in code world - I got it to work, I'm out of here.
Back to top
View user's profile Send private message
jjmckenzie51
The Anomaly


Joined: Apr 01, 2005
Posts: 1055
Location: Southeastern Arizona

PostPosted: Tue Mar 14, 2006 3:43 am    Post subject: Re: 2.0.2rc4 - to print (or not to print) Reply with quote

LJHeal wrote:
Well, I suppose before I announce the workaround I should try to print something, not just take spadmin at its word...yep, blank page out.


First, I must state again, spadmin is not used with the MacIntosh version of OpenOffice. You have to add your printer to the Printers item. OpenOffice will 'pick up' your printer from it.

LJHeal wrote:

These builds (rc3, rc4 tried) downloaded from ftp://ooopackages.good-day.net/pub just did not want to create a printer-type, Generic or no, on this 10.3.9 system.


Ok. This is expected. However, when you selected a printer to print from out of the print dialog, were there ANY printers available to print to?

LJHeal wrote:

Tried fooling it by pointing into OO2.0, no luck. Tried copying out the share/psprint directory (and the spadmin & spadmin.bin tools) from OO2.0 into OO2.0.2rc4, luck.


This is highly NOT recommended. There have been MANY changes to OpenOffice since the 2.0 release, especially where your prefences are located.

[quote="LJHeal"
It's sad to be in user land when you used to be in code world - I got it to work, I'm out of here.[/quote]

Sorry that you had so many problems with printing but could you try the following for me:

First and formost reinstall the 2.0.2 rc 4 program. Remove any contents in the ~ (or your user) /Library/Application Support/OpenOffice.org 2.0 directory.
1. Create a short writer document. It does not matter what you do. Should be about a page in length (could be shorter if you wish.)
2. Select print from the file top menu (or you can use Cntrl+P)
3. Does the print dialog box appear? Yes or No.
4. If the print dialog box appears, is the printer you want to print to appear? Yes or No
5. If the printer want to print to does not appear, does the generic printer appear? Yes or No
6. If the printer you want to use appears, attempt to print to it. Does the document print? Yes or No
7. If the document did NOT print, did you get only a blank page? Yes or No.
8. Did anything print? Yes or No
9. Is the printer a local (connected to your Mac) or a networked printer?

Your responses will be used to build/update an Issue.

Thank you.
James
Back to top
View user's profile Send private message
LJHeal
Red Pill


Joined: Mar 14, 2006
Posts: 7

PostPosted: Sun Mar 19, 2006 8:01 am    Post subject: Re: 2.0.2rc4 - to print (or not to print) Reply with quote

jjmckenzie51 wrote:

>Sorry that you had so many problems with printing but could you try the
>following for me:

>First and formost reinstall the 2.0.2 rc 4 program. Remove any contents
>in the ~ (or your user) /Library/Application Support/OpenOffice.org 2.0
>directory.

Since I had already learned the wisdom of keeping a bootable partition on a Firewire drive, and was running from it at the time, no problem.

>1. Create a short writer document. It does not matter what you do. >Should be about a page in length (could be shorter if you wish.)
>2. Select print from the file top menu (or you can use Cntrl+P)
>3. Does the print dialog box appear? Yes or No.

The dialog appears: (X) No default printer found. Please choose a printer and try again. <<Okay>>

The Print dialog appears with dropdown and OK buttons greyed. Options... is not useful (dropdown has only <None>).

4. If the print dialog box appears, is the printer you want to print to appear? Yes or No

Is..to, does, no, no.

5. If the printer want to print to does not appear, does the generic printer appear? Yes or No

No. Printer Settings... gives the first error dialog as above, then a dialog that can only be cancelled.

6. If the printer you want to use appears, attempt to print to it. Does the document print? Yes or No
7. If the document did NOT print, did you get only a blank page? Yes or No.
8. Did anything print? Yes or No
9. Is the printer a local (connected to your Mac) or a networked printer?

I access them through TCP. Just for grins and giggles I suppose I could plug the Brother 8840D into the USB port - the HP installer ignores both of my Macintoshes' USB ports...and the answer is...the cable is too short...but I knew that USB extender would come in handy sometime...

Which works with all of the automagic that USB promises - from a native app -

But OO2.0.2rc4 still balks at allowing print. Restart, same problem.

Over to sudo ./spadmin - which, with a USB printer attached, shows it -- and a Generic Printer (different from before). Odds are the Generic Printer will show if the preferences are deleted, then. But the network printers are not available. Of course, unless I plug the USB cord into the wireless adapter, the network printer is indeed unavailable. Also, the HP which is a shared SMB (PostScript) printer is also not shown.

And an attempt to click the New printer... button leaves the machine cold, frozen even. Interesting OSX wheel of misfortune spinning just under the dialog.

Time to boot off the internal disk and resynch its clone.

>Your responses will be used to build/update an Issue.

>Thank you.
>James

My pleasure. Sorry I can't help with the recoding.
Back to top
View user's profile Send private message
jjmckenzie51
The Anomaly


Joined: Apr 01, 2005
Posts: 1055
Location: Southeastern Arizona

PostPosted: Sun Mar 19, 2006 2:35 pm    Post subject: RE: Re: 2.0.2rc4 - to print (or not to print) Reply with quote

LJHeal wrote:
jjmckenzie51 wrote:

3. Does the print dialog box appear? Yes or No.

The dialog appears: (X) No default printer found. Please choose a printer and try again. <<Okay>>

The Print dialog appears with dropdown and OK buttons greyed. Options... is not useful (dropdown has only <None>).


Can you open the Printer Setup Utility and look for these printers?

What does it report?

James
Back to top
View user's profile Send private message
LJHeal
Red Pill


Joined: Mar 14, 2006
Posts: 7

PostPosted: Tue Mar 21, 2006 11:59 pm    Post subject: Reply with quote

Printer Setup Utility opened. Printers found.

Even though the two USB printers are not now plugged in.

After a bit more probing it looks like the psprint.conf file I am getting from the RC4 distribution is munged. At least, there is whitespace at the top and the bottom cuts off at Comment= or so. And even typing in to be an exact match of the psprint.conf file still leaves no printer available.

Either it is my imagination in the throes of testing or I still have to copy the entire contents of the earlier psprint folder to the later one to make things work. Maybe something else did not pack,unpack or transfer correctly too. And the problem occurs in RC3 and RC4.

The spadmin utility has not been helpful and the sudden appearance of the Generic and Brother printers (followed by the sudden crash of the system) has not recurred. As I think about it, file corruption could explain these errors too.
Back to top
View user's profile Send private message
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> OpenOffice.org MacOS X X11 Support All times are GMT - 7 Hours
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.08 Seconds