Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2022? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - OO 1.0 for OSX Font "Smearing" Issue
OO 1.0 for OSX Font "Smearing" Issue
 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> OpenOffice.org X11 Testing
View previous topic :: View next topic  
Author Message
BRnPA
Blue Pill


Joined: Jul 01, 2003
Posts: 2

PostPosted: Tue Jul 01, 2003 12:06 pm    Post subject: OO 1.0 for OSX Font "Smearing" Issue Reply with quote

Hi:

I was running the latest pre-release beta under OSX (10.2.6) with Apple X11 and it was fine. I installed the 1.0 realease Friday and here's what I'm seeing: my fonts in the menus are aliased and off color. For example, the "File" menu item is "washed out" for a better lack of a term. It looks smeared and the color is a smeared reddish. The menu item to the right of it looks perfectly fine, though. I'm seeing this in all the OO apps I bring up. Any ideas what could be causing this? I have font smoothing 'on' in OSX above 8 point. It's strange that the pre-release worked fine and now this issue and I changed nothing....

Thanks,

Bill Rose
Back to top
View user's profile Send private message
fa
The Architect
The Architect


Joined: May 27, 2003
Posts: 88

PostPosted: Wed Jul 02, 2003 11:52 am    Post subject: Reply with quote

Hi,

We don't really interface with the Mac OS X font antialiasing preferences. Its all through Freetype. However, if you are running in Thousands of colors, switch to Millions and it will look a lot better (so I hear).

Dan
Back to top
View user's profile Send private message
BRnPA
Blue Pill


Joined: Jul 01, 2003
Posts: 2

PostPosted: Thu Jul 03, 2003 6:24 am    Post subject: Font Smear Fixed! Reply with quote

Hi:

Yes, that fixed it. Thanks,

Bill
Back to top
View user's profile Send private message
OPENSTEP
The One
The One


Joined: May 25, 2003
Posts: 4752
Location: Santa Barbara, CA

PostPosted: Thu Jul 03, 2003 9:27 am    Post subject: Reply with quote

Does anyone really understand the technical reasons behind why Apple X11 is functioning differently in thosands and millions of colors mode? The only thing that comes to my mind is that freetype/xrender may be doing continual 32 bit antialiasing, which looks like c*** when rendered as 16 bit colors.

Perhaps we need to set a flag for the pixel depth used for xrender's antialiasing? I've never seen such a call, though.

ed
Back to top
View user's profile Send private message Visit poster's website AIM Address
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> OpenOffice.org X11 Testing All times are GMT - 7 Hours
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.03 Seconds