Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2022? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - Copy and paste patch available
Copy and paste patch available
 
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Testing
View previous topic :: View next topic  
Author Message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11932

PostPosted: Mon Jan 19, 2004 1:04 pm    Post subject: Copy and paste patch available Reply with quote

All,

I finally got around to implementing copy and paste in NeoOffice/J and, since so many people have been waiting for this functionality, I have posted a patch and it is ready for testing.

Although I only impemented copy and paste of text (I will implement copy and paste of images soon), please help test this patch and help me find any bugs.

If you are interested in testing this patch, you can download the lastest patch binaries and install them in an existing NeoOffice/J 0.7.1 installation using the following steps.

- If you have not already installed NeoOffice/J 0.7.1, download and install it from:
http://www.planamesa.com/neojava/download.php
- Download the latest patch binaries from:
http://www.planamesa.com/neojava/downloads/temp/NeoOfficeJ-0.7.1-patch-3.tar.gz
- Open a new terminal and execute the following commands to unzip the file:
Code:
cd <NeoJ installation directory>/NeoOfficeJ.app
sudo tar zxvf <path to downloaded *.tar.gz file>


Please reopen any of the bugs in Bugzilla that do not seem to be fixed with this patch.

Patrick
Back to top
View user's profile Send private message Visit poster's website
Adrian
Guest





PostPosted: Mon Jan 19, 2004 7:47 pm    Post subject: No fonts at all... Reply with quote

I have been running 0.7 for a while, only customization was to add
extra TT fonts for Staroffice and Sun typefaces to the share/fonts/truetype directory, as I do for ooo-1.0.3. Then I upgraded to OSX 10.3.

I loaded 0.7.1 as an upgrade and all the fonts got lost, no menus or anything in the whole application. No space for the text, as if the font size was zero. It crashed if I clicked on anything.

I deleted the whole package and did a clean install, also deleted my own user files directory. No change.

I loaded patch 1 and it did the same thing, but didn't crash

I loaded my custom fonts into the share/fonts/truetype dir and it came up with junk fonts, mostly squares where letters should be for menus etc.

I deleted the files and it went back to missing/zero point

I used the font book app to add the new fonts to the system, and that didn't help either.

I loaded patch 3, no change. If I had a font I could test cut and paste
Help....
Crying or Very sad
Back to top
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11932

PostPosted: Mon Jan 19, 2004 8:00 pm    Post subject: Reply with quote

The share/fonts/truetype directory is used only by the OOo X11 version. NeoOffice/J uses native fonts which means that it only loads fonts in the standard /Library/Fonts and ~/Library/Fonts directory. So try moving your fonts to either of these standard Mac OS X font directories.

Since 0.7.1 without any patches crashes and with patch-1 it does not crash, I have to assume that you have many fonts disabled in the FontBook application. Having a disabled font makes them unloadable by applications such as NeoJ so try enabling all of the fonts in FontBook.

Hope that helps,

Patrick
Back to top
View user's profile Send private message Visit poster's website
jimlaurent
Captain


Joined: Jun 23, 2003
Posts: 55

PostPosted: Mon Jan 19, 2004 8:17 pm    Post subject: Reply with quote

Patch 3 does not appear to paste the "return" character. If I copy multiple paragraphs from Mozilla and paste into Neo/J any "return" chars are turned into spaces.

This is different than a basic Mac app such as text edit which make separate paragraphs.

Other than than, it seems fairly stable.
Back to top
View user's profile Send private message
Adrian
Guest





PostPosted: Mon Jan 19, 2004 8:29 pm    Post subject: Reply with quote

pluby wrote:
The share/fonts/truetype directory is used only by the OOo X11 version. NeoOffice/J uses native fonts which means that it only loads fonts in the standard /Library/Fonts and ~/Library/Fonts directory. So try moving your fonts to either of these standard Mac OS X font directories.

Since 0.7.1 without any patches crashes and with patch-1 it does not crash, I have to assume that you have many fonts disabled in the FontBook application. Having a disabled font makes them unloadable by applications such as NeoJ so try enabling all of the fonts in FontBook.

Hope that helps,

Patrick


I don't have any disabled fonts as far as I can tell.
And I have loaded my custom fonts into fontbook. There must be something else wrong....
Back to top
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11932

PostPosted: Mon Jan 19, 2004 8:41 pm    Post subject: Reply with quote

jimlaurent wrote:
Patch 3 does not appear to paste the "return" character. If I copy multiple paragraphs from Mozilla and paste into Neo/J any "return" chars are turned into spaces.

This is different than a basic Mac app such as text edit which make separate paragraphs.

Other than than, it seems fairly stable.


When I copy an HTML page with <p> tags in them (like this page) from Mozilla 1.3, the newlines are rendered when I paste the text into NeoJ. Is there a page I can test that does shows this behavior?

Patrick
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11932

PostPosted: Mon Jan 19, 2004 9:31 pm    Post subject: Re: No fonts at all... Reply with quote

Adrian wrote:
I loaded my custom fonts into the share/fonts/truetype dir and it came up with junk fonts, mostly squares where letters should be for menus etc.


I forget that, at startup, NeoJ creates a softlink in your ~/Library/Fonts directory that links to all fonts in the NeoOfficeJ.app/Contents/share/fonts/truetype directory. Can you try the following and see if it helps?:

1. Delete all softlinks in your ~/Library/Fonts directory and restart NeoJ

If that doesn't work:

2. Delete your ~/Library/NeoOfficeJ directory (i.e. your NeoJ settings) and restart NeoJ

Patrick
Back to top
View user's profile Send private message Visit poster's website
Adrian
Guest





PostPosted: Tue Jan 20, 2004 1:41 am    Post subject: Re: No fonts at all... Reply with quote

pluby wrote:

I forget that, at startup, NeoJ creates a softlink in your ~/Library/Fonts directory that links to all fonts in the NeoOfficeJ.app/Contents/share/fonts/truetype directory. Can you try the following and see if it helps?:

1. Delete all softlinks in your ~/Library/Fonts directory and restart NeoJ

If that doesn't work:

2. Delete your ~/Library/NeoOfficeJ directory (i.e. your NeoJ settings) and restart NeoJ

Patrick


I found the bad softlinks and deleted them, deleted the ~/Library/NeoOfficeJ and also found and deleted my preferences file
It was still broken.

So I deleted every trace of NeoOffice from my system, and installed again from scratch, with patch3 and it is working properly now.

Thanks for the advice, I'll let you know how cut and paste goes

Cheers Adrian
Back to top
jimlaurent
Captain


Joined: Jun 23, 2003
Posts: 55

PostPosted: Tue Jan 20, 2004 7:20 am    Post subject: Reply with quote

Patrick,

That's interesting that it works for you because I just copied and pasted from this page (both quoted text and standard text) and paragraph markers do NOT come through.


Interestingly enough, if I copy the text from Moz to Neo/J, and then copy it back, the paragraphs appear again. Is there a Neo/J option for displaying paragraphs differently? I've turned on "View: Non-printing characters" and there are no paragraph markers.

I stand corrected, however, on my earlier post. Neo/J doesn't convert them to spaces but simply runs the text of the new paragraph right up to the last letter of the previous.

I'll email you the sample doc.
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11932

PostPosted: Tue Jan 20, 2004 7:47 am    Post subject: Reply with quote

Jim,

I figured out the problem late last night. The problem is that Mozilla is using the Mac OS Classic newline character (i.e. '\c') in its text instead of the Mac OS X newline character (i.e. '\n').

Since there are still quite a few Mac OS X applications that still insist on using the Classic newline character, I added code that replaces all '\c' characters with '\n' in text data that is fetched from the clipboard.

Patrick
Back to top
View user's profile Send private message Visit poster's website
jimlaurent
Captain


Joined: Jun 23, 2003
Posts: 55

PostPosted: Tue Jan 20, 2004 3:38 pm    Post subject: Reply with quote

I'm glad you found that but it still doesn't explain why it worked for you and not for me in mozilla.

It also doesn't explain why, when I copy the text from Neo/J that "appears" to have no paragraph markers, it pastes back into something else WITH paragraphs.

Are there some other hidden chars going in there?

Frankly, just having cut/paste is a blessing.
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11932

PostPosted: Tue Jan 20, 2004 3:41 pm    Post subject: Reply with quote

The difference is that we are probably using different versions of Mozilla. Mozilla has slowly migrated from the Mac Classic code base with each version and it kept the use of Mac Classic newlines until fairly recently.

I believe that Mozilla 1.3 was the first to switch to Unix newlines.

Patrick
Back to top
View user's profile Send private message Visit poster's website
jakeOSX
Ninja
Ninja


Joined: Aug 12, 2003
Posts: 1373

PostPosted: Tue Jan 20, 2004 4:23 pm    Post subject: Reply with quote

I played with it some. From Chimera and from Terminal I get the same affect where the text does not have carrage returns.

now I opened a NeoJ doc (in NeoJ) and cut from Neo to Word and got a similar response where instead of paragraphs i got squares and it all in one blob.

cutting Chimera and Terminal Text from NeoJ to Word resulted in properly formatted text. Cutting from NeoJ to Word and back Neo, formatting was not regained from Word to Neo (from the orignial NeoJ doc).

I'll keep playing with it (and the terminal command, which for some reason I couldn't get to work, my Unix must be much worse than I thought)

Oh, and I am running Panther now.

-j
Back to top
View user's profile Send private message
jakeOSX
Ninja
Ninja


Joined: Aug 12, 2003
Posts: 1373

PostPosted: Tue Jan 20, 2004 4:31 pm    Post subject: Reply with quote

oh, and I don't know if it is supposed to yet... but I'd thought I'd meantion that formatting (fonts, colors, etc) do not get pasted into NeoJ.

-j
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11932

PostPosted: Tue Jan 20, 2004 10:52 pm    Post subject: Reply with quote

Jake,

First, you are not seeing any formatting (font, bolding, etc.) because I did not enable RTF as a supported data type. I only enabled plain text and Unicode text.

The missing newlines are due to the fact that I was not handling the Mac Classic newlines that some applications still insist on using.

I have add RTF support and I have changed the text handling to convert OOo's use of Unix newlines to Mac Classic newlines.

I should have a patch in the next day or so. I am just putting the finishing touches on copy and paste of images in both PICT and TIFF format.

Patrick
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Testing All times are GMT - 7 Hours
Goto page 1, 2, 3, 4, 5  Next
Page 1 of 5

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.03 Seconds