Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2017? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - Problems with special characters like Ohm, Rho, Lambda etc.
Problems with special characters like Ohm, Rho, Lambda etc.
 
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Releases
View previous topic :: View next topic  
Author Message
Bastian
Guest





PostPosted: Thu Jan 18, 2007 12:47 am    Post subject: Problems with special characters like Ohm, Rho, Lambda etc. Reply with quote

Hello!

My professor provides from time to time some exercises as .doc files. When I open these files with MS Office 2004 it's showing me all the special characters correctly. But I don't wanna use MS Office for some reasons (I can run it only with admin rights, it's just the trial version). Unfortunately NeoOffice doesn't give me the special characters, they all are removed or replaced by standard letters. Had someone the same problem and found a solution for it?

Thanks
Bastian
Back to top
sardisson
Town Crier
Town Crier


Joined: Feb 01, 2004
Posts: 4588

PostPosted: Thu Jan 18, 2007 1:33 am    Post subject: Reply with quote

Without seeing the document, this is either the famed "other OOo modules use a different rendering engine than Math" OOo bug, or the "MS Office/MS Windows apps mis-encode Greek characters" bugs (see bug 747 / bug 1040 / bug 1704).
_________________
"[...] whether the duck drinks hot chocolate or coffee is irrelevant." -- ovvldc and sardisson in the NeoWiki
Back to top
View user's profile Send private message Visit poster's website
Bastian
Guest





PostPosted: Thu Jan 18, 2007 10:05 am    Post subject: Reply with quote

Thanks for your help sardisson. I tried a few things after I had read the bugzilla articles you had sent me.

First I opened the word document in TextEdit and the greek symbols are shown correctly. Then I opened that document in OpenOffice.org 2.1 on a windows computer, also no problem. It also seems to me that my professor didn't use the equation editor. If you have time to help me I could send you that file or put it on a server and post the link.
Back to top
jgd
Agent Smith


Joined: Feb 27, 2005
Posts: 1531
Location: France

PostPosted: Thu Jan 18, 2007 10:13 am    Post subject: Reply with quote

Maybe you an get help from the wiki
http://neowiki.sixthcrusade.com/index.php/Problems_with_the_Symbol_font%2C_Greek_text%2C_or_bullets_in_Word_documents

I know that there are problems with math documents written in MSOffice when opening them in Neo (or OOo).

Jacqueline
Back to top
View user's profile Send private message AIM Address
sardisson
Town Crier
Town Crier


Joined: Feb 01, 2004
Posts: 4588

PostPosted: Thu Jan 18, 2007 1:52 pm    Post subject: Reply with quote

I'll be happy to have a look at the file if you want to post it somewhere and post the link.

Smokey

_________________
"[...] whether the duck drinks hot chocolate or coffee is irrelevant." -- ovvldc and sardisson in the NeoWiki
Back to top
View user's profile Send private message Visit poster's website
Bastian
Guest





PostPosted: Thu Jan 18, 2007 3:39 pm    Post subject: Reply with quote

Just the link to one of the files which makes problems. Keep looking for Ohm and My (micro) (i get only rectangles).

http://web.mac.com/viatorius/iWeb/Web-Site/Leer_files/etechnik009.doc
Back to top
Bastian
Guest





PostPosted: Thu Jan 18, 2007 3:45 pm    Post subject: Reply with quote

I just found that. I guess it answers my question. Unfortunately there is no real solution for my problem. But thanks for your help guys.


Greek characters and bullets in Word (or OpenOffice.org for Windows) documents don't display correctly

This is because these characters were entered with non-Unicode values in Word, and the OpenOffice.org import filters do not convert the characters to Unicode ones. This seems to be Mac-only OOo bug (or a bug that is only manifest on the Mac, since OOo on Windows has access to Microsoft fonts and Windows methods of mapping characters). Unfortunately, since this bug appears to be Mac-only and Mac OS X is not a "tier 1" platform for Sun and OpenOffice.org, the OpenOffice.org developers who could fix the bug seem to have ignored it.
There is a very hacky work-around available in NeoBugzilla Bug 912 that will allow you to force the characters to display properly, but it will break proper handling of Greek, symbols, and bullets in the rest of your Mac applications and it will not actually "fix" the characters—only make them display as they did in Word or on Windows so you can, eg., produce a hard copy with the correct appearance.
Back to top
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11902
Location: California, USA

PostPosted: Thu Jan 18, 2007 4:59 pm    Post subject: Reply with quote

There is one other workaround. It's a hassle, but it won't destroy any data:

1. Opent the /Applications/Font Book application
2. Click on the "Symbol" font.
3. Select the Edit -> Disable Symbol Family menu item
4. Restart NeoOffice

Patrick
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11902
Location: California, USA

PostPosted: Thu Jan 18, 2007 6:42 pm    Post subject: Reply with quote

FYI. A fix for this OpenOffice.org bug will be include in upcoming NeoOffice 2.1 release. It was tricky to implement, but NeoOffice 2.1 will force ooo-build's enhanced OpenSymbol font to be used when a document wants to use the Symbol font.

Patrick
Back to top
View user's profile Send private message Visit poster's website
Bastian
Guest





PostPosted: Fri Jan 19, 2007 2:30 am    Post subject: Reply with quote

Thanks again. To print my electrical engineering documents I will disable the symbol font. And for the future I look forward to 2.1.
Back to top
Display posts from previous:   
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Releases All times are GMT - 7 Hours
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.02 Seconds