Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2017? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - Template Management
Template Management
 
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Releases
View previous topic :: View next topic  
Author Message
straydog
Blue Pill


Joined: Dec 24, 2006
Posts: 3
Location: Australia

PostPosted: Thu Jan 11, 2007 8:22 pm    Post subject: Template Management Reply with quote

Greetings.

I am in the process of migrating from WIN to MAC, and just to complicate things, from MS Office to NeoOffice. I wa When I go there the only s pleased to see the NeoOffice was able to faultlessly convert more than 100 of my Word templates to .ott format, however getting them in the right place has has proved to be impossible for me.

One problem is that NeoOffice Help says under "Template Management" that I can change the default template path under Tools - Options - NeoOffice - Paths. When I go there the only paths available are Backups, Gallery, Graphics. My documents, Temporary files. No Templates.

My imported templates were placed in Library - Preferences - NeoOffice-2.x - User - Templates - then my folders containing the template files.

I used the Template Management window to create my template folders and was able to import some of the templates, but when importing to other folders I am told the files of that name already exist.

What am I doing wrong??
TIA Robert.
Back to top
View user's profile Send private message
Lorinda
Captain Mifune


Joined: Jun 20, 2006
Posts: 2051
Location: Midwest, USA

PostPosted: Thu Jan 11, 2007 9:02 pm    Post subject: Reply with quote

Did you move the templates into the folders manually, or are you only importing them from the Template Management dialog? I've been successful either way, but I've heard of some folks who can't get Neo to recognize templates they move into the folders manually.

Are you having problems moving templates into particular folders? It is not possible to add templates to the "Presentations" or "Presentation Backgrounds" folders. These are stored elsewhere and users don't have write permissions for that location.

I'm not sure why the help says you can modify the paths in the Tools>Options (same as NeoOffice>Preferences) when you actually can't. As I understand it, the help files are simply OpenOffice's help files, with a few "global search and replaces" done to replace Open Office with NeoOffice, etc. Maybe it is an error in the Open Office help??? (I don't have Open Office, so I can't check this.)
Back to top
View user's profile Send private message
jgd
Agent Smith


Joined: Feb 27, 2005
Posts: 1531
Location: France

PostPosted: Fri Jan 12, 2007 3:58 am    Post subject: Reply with quote

Lorinda wrote:
I'm not sure why the help says you can modify the paths in the Tools>Options (same as NeoOffice>Preferences) when you actually can't. As I understand it, the help files are simply OpenOffice's help files, with a few "global search and replaces" done to replace Open Office with NeoOffice, etc. Maybe it is an error in the Open Office help??? (I don't have Open Office, so I can't check this.)


You can edit the paths in OOo because Templates appears in Tools -> Options -> Ooo -> Paths, but Templates is missing in the same location in Neo. Is that a little bug ?

Jacqueline
Back to top
View user's profile Send private message AIM Address
dndrich
Operator


Joined: Jan 03, 2007
Posts: 43

PostPosted: Tue Jan 16, 2007 11:35 am    Post subject: Reply with quote

If you search this forum you will see a thread on this started by me. I had the same problem. It turns out in NeoOffice that you have to import the templates from the organize templates dialog. What you do is convert your templates to open office format, which it looks like you have done. Store them in some folder somewhere. Then, go to the organize templates dialog. Make a new folder there. You cannot import them into the default folders provided. Once you are in the new folder, go to the options pull down and select import. You can highlight all of them if you want. You do not have to just import one at a time. Once you do that, they will all be available from the new document from template dialog. It works perfectly. The inability to choose a path for templates I do not believe is a bug. I just think that is how they elected to organize NeoOffice. It is different than OpenOffice.

Daniel
Back to top
View user's profile Send private message
guest
Guest





PostPosted: Tue Jan 16, 2007 7:42 pm    Post subject: Problems with import Reply with quote

Hi everybody!

I have some original .ott templates that I need to appear in the organizer. Problem is, they don't. I've tried importing manually, importing per the second and third methods in the wiki, and I'm pulling my hair out because although I can import it, the moment I press "Update" or leave the program, although the file stays in the ~/Library/...(that long path) folder, it disappears from the organizer!

I've searched the forums and Google extensively, as well, but to no avail. Any advice?

Thanks!
Back to top
guest
Guest





PostPosted: Tue Jan 16, 2007 7:57 pm    Post subject: I should add... Reply with quote

Sorry, guys, forgot to mention: I'm running on an MB Pro with 10.4.8, NeoOffice 2.0 Aqua Beta Patch 11.
Back to top
Lorinda
Captain Mifune


Joined: Jun 20, 2006
Posts: 2051
Location: Midwest, USA

PostPosted: Tue Jan 16, 2007 8:42 pm    Post subject: Reply with quote

Patrick just released patch 12. I would suggest upgrading to patch 12 and see if that makes a difference. I can't reproduce the disappearances you describe on my iBook.
Back to top
View user's profile Send private message
guest
Guest





PostPosted: Tue Jan 16, 2007 8:59 pm    Post subject: Update Reply with quote

I just upgraded to Patch 12, but noticed no difference whatsoever. Thanks for responding, by the way!

Repro steps are:

1. Launch NeoOffice.
2. File > Templates > Organize.
3. Select either "My Templates" or any other non-built-in folder (I tried both "My Templates" and one I created called "Academics").
4. Commands > Import Template...
5. Navigate to and select template to import and press "Open".
6. New entry beneath the template region selected appears.
7. Control-click on region in question and press "Update".
8. Poof! All the regions minimize.
9. Re-open region in question to discover that the template is no longer there.
Back to top
Lorinda
Captain Mifune


Joined: Jun 20, 2006
Posts: 2051
Location: Midwest, USA

PostPosted: Tue Jan 16, 2007 9:04 pm    Post subject: Reply with quote

What happens if you skip the update step?

I don't think I've ever used update (until I tried to reproduce your problem), and my templates have stayed put.
Back to top
View user's profile Send private message
guest
Guest





PostPosted: Tue Jan 16, 2007 9:44 pm    Post subject: Reply with quote

Without clicking "Update", it stays there, and I can use the template for as long as NeoOffice is open without having to reimport it. After closing NeoOffice, though, and reopening, the template isn't there any more! I have to reimport it to use it again. Needless to say, that's a royal pain in the butt.
Back to top
straydog
Blue Pill


Joined: Dec 24, 2006
Posts: 3
Location: Australia

PostPosted: Tue Jan 16, 2007 9:53 pm    Post subject: Re: Update Reply with quote

Hi Guest
guest wrote:
1. Launch NeoOffice.
2. File > Templates > Organize.
3. Select either "My Templates" or any other non-built-in folder (I tried both "My Templates" and one I created called "Academics").
4. Commands > Import Template...
5. Navigate to and select template to import and press "Open".
6. New entry beneath the template region selected appears.
7. Control-click on region in question and press "Update".
8. Poof! All the regions minimize.
9. Re-open region in question to discover that the template is no longer there.

I started this thread and still have not come to understand the unpredictability of the process, however, I used your 9 steps with success. The fact that it doesn't work for you is no surprise because I have often worked through a process that seemed to be working for me only to find that the templates had vanished when I went back to them.

Still persisting with it though.

PS It would be nice if the template management window was MAC-like.
Back to top
View user's profile Send private message
Lorinda
Captain Mifune


Joined: Jun 20, 2006
Posts: 2051
Location: Midwest, USA

PostPosted: Wed Jan 17, 2007 10:40 am    Post subject: Reply with quote

Hmmm... My templates stay put with no problem. Maybe it's related to the fact that I'm working on a PPC machine and you are on a Intel machine???

A couple of more things to try:

Fix disk permissions using Disk utilities

Restart your computer (unless you've tried that already)

Move the NeoOffices Preferences file (User/Library/Preferences/NeoOffice-2.x) to your desktop or some other safe place and restart NeoOffice.
Then try importing a few templates, quitting, and restarting.
If the templates stay put, you probably have some corrupted preferences. If you want to be able to salvage the uncorrupted preferences, you can follow the instructions I provided in this thread.


Also are you running any "haxies" to change the look and feel or the operation of OSX?

If none of the suggestions above work, and noone else has any suggested fixes, it's probably time to file a bug report.
Back to top
View user's profile Send private message
dndrich
Operator


Joined: Jan 03, 2007
Posts: 43

PostPosted: Wed Jan 17, 2007 10:49 am    Post subject: Reply with quote

Interesting. I am running a new Macbook Core 2 duo Intel machine. I have no problem with the templates not staying. It works perfectly.

Daniel
Back to top
View user's profile Send private message
guest
Guest





PostPosted: Wed Jan 17, 2007 7:12 pm    Post subject: Reply with quote

Lorinda wrote:
Hmmm... My templates stay put with no problem. Maybe it's related to the fact that I'm working on a PPC machine and you are on a Intel machine???

A couple of more things to try:

Fix disk permissions using Disk utilities


Done.

Lorinda wrote:
Restart your computer (unless you've tried that already)


Done.

Lorinda wrote:
Move the NeoOffices Preferences file (User/Library/Preferences/NeoOffice-2.x) to your desktop or some other safe place and restart NeoOffice.
Then try importing a few templates, quitting, and restarting.
If the templates stay put, you probably have some corrupted preferences. If you want to be able to salvage the uncorrupted preferences, you can follow the instructions I provided in this thread.


Done. Templates in question do not stay put.

Lorinda wrote:
Also are you running any "haxies" to change the look and feel or the operation of OSX?


No.

Lorinda wrote:
If none of the suggestions above work, and noone else has any suggested fixes, it's probably time to file a bug report.


Going over to do so right now...thanks to everybody for helping out!
Back to top
straydog
Blue Pill


Joined: Dec 24, 2006
Posts: 3
Location: Australia

PostPosted: Wed Jan 17, 2007 7:16 pm    Post subject: Reply with quote

Running NeoOffice 2.0 Aqua Beta 3 Patch 12 on Intel iMac.

I have carefully checked the process of converting a MS Word template to a NeoOffice .ott template file and storing it in user/library/preferences/NeoOffice-2.x/template/myfolder like this.

file>template>organize
open myfolder
command>import template
browse to the .ott file and click open
the file appears in the myfolder
then open template management window - the file has gone

Then I created a NO template from scratch using the NO tools. Stored it away - it stayed there and I was able to use it to create a new document.

Then I opened one of the converted Word templates,
select all>copy>paste into the newly opened NO document then
file>template>save
The document was successfully saved as a NO template with the Word content and formatting and could be used to create a new document.

This shows that:

NeoOffice correctly handles the creation and storage of its own templates.

A NeoOffice document with Word document content and formatting can be saved as a .ott template in the correct place and be used as expected.

NeoOffice is not able to save a converted Word template as an .ott document template in the correct location using the above procedure.

==================

Now on a different but related topic. I managed to get some Word templates in the right place as NO templates but at the time I was highly agitated and don't recall how I did it, except it might have been via the file button in the template management window.

Anyway, I decided to use the finder to re-name the .ott files so that they would list in a logical sequence. That caused them to vanish from the NO template folder. Grrrrr!

Spotlight found them with their original names in the trash.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Releases All times are GMT - 7 Hours
Goto page 1, 2  Next
Page 1 of 2

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.02 Seconds