Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2017? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - start-up slowed
start-up slowed
 
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Testing
View previous topic :: View next topic  
Author Message
Paraplegic_Racehorse
Pure-blooded Human


Joined: Jun 23, 2003
Posts: 36
Location: Seward, Alaska, USA

PostPosted: Thu Feb 26, 2004 1:33 pm    Post subject: start-up slowed Reply with quote

I just upgraded from 0.8.0patch3 to 0.8.1patch1 (yes, all at once). On my iMac DV 500/512RAM/Panther/Java 1.4.2 (JDK, too), application start-up time has increased nearly 50%. Quit time also increased similarly. Everything else actually feels slightly more snappy.

On the bright side, quitting the app w/o any open windows from the Apple menu bar now functions (didn't in 0.7.0 and I didn't test in 0.8.0). Still, it would be nice to be able to open a new window from that menu.

Also, I haven't checked the available tasks for contribution [blush] so.... How difficult, in your humble opinion, would it be for a non-programmer to port the help system into the OSX native system?

_________________
Faster than a speeding slug!
I'm Paraplegic Racehorse.
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11907
Location: California, USA

PostPosted: Thu Feb 26, 2004 2:39 pm    Post subject: Re: start-up slowed Reply with quote

Paraplegic_Racehorse wrote:
I just upgraded from 0.8.0patch3 to 0.8.1patch1 (yes, all at once). On my iMac DV 500/512RAM/Panther/Java 1.4.2 (JDK, too), application start-up time has increased nearly 50%. Quit time also increased similarly. Everything else actually feels slightly more snappy.


Is it always slower or was it slower the first time you ran NeoJ 0.8.1? The first time NeoJ is run after booting (and a NeoJ install or upgrade is no different), start up will be very slow because Mac OS X is loading all of NeoJ's binary files into memory. The next time you start NeoJ, startup time will drop significantly since the virtual memory manager will already have the binary files loaded in memory from the last time that you ran NeoJ.

To you a sense of the different, here are the startup times on my G4 450 MHz PowerBook with 768 MB of memory:


- First startup after booting: 21 seconds for splash screen and 41 seconds for the first document window to appear

- Second startup: 7 seconds for splash scrren and 19 seconds for the first document window to appear

Paraplegic_Racehorse wrote:
Also, I haven't checked the available tasks for contribution [blush] so.... How difficult, in your humble opinion, would it be for a non-programmer to port the help system into the OSX native system?


The underlying OOo code uses lots of C++ code to manage help files. In other words, this is no small undertaking. Also, even if you figure it out and change all the code (I'm not going to even start down that path as this is more in line with the goals of NeoOffice, not NeoOffice/J), you would need to go through and convert all of the localized help files (e.g. French, German, Italian, Russian, Japanese, etc.) that are published by the OOo documentation teams.

Patrick
Back to top
View user's profile Send private message Visit poster's website
sardisson
Town Crier
Town Crier


Joined: Feb 01, 2004
Posts: 4588

PostPosted: Thu Feb 26, 2004 11:05 pm    Post subject: Re: start-up slowed Reply with quote

pluby wrote:
To you a sense of the different, here are the startup times on my G4 450 MHz PowerBook with 768 MB of memory:


- First startup after booting: 21 seconds for splash screen and 41 seconds for the first document window to appear

- Second startup: 7 seconds for splash scrren and 19 seconds for the first document window to appear


I thought it felt slower, too, but my times seem pretty equivalent to Patrick's:

- Not positive it was 1st launch after a reboot, but was definitely 1st launch after installing a patch: 17 sec to splash, 29 sec to first doc window.

- Second startup: 9 sec, 17 sec

PowerBook G4 1.33 GHz, 512 MB of RAM
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Testing All times are GMT - 7 Hours
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.02 Seconds