Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2017? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - Hard-to-read setup
Hard-to-read setup
 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> NeoOffice/C Testing
View previous topic :: View next topic  
Author Message
Thomas Schlesinger
Guest





PostPosted: Sat Jun 07, 2003 5:02 am    Post subject: Hard-to-read setup Reply with quote

Hello,

this morning I've built - like every saturday - a new NeoOffice from CVS. Several dialogues of the setup were hard to read because of overlapping text lines. The purpur text field in the middle of the installation screen displayed the text "on the head" and needed sometimes a long time to change its content (I could watch the pixel columns of this text area while slowly changing). I've built on my "Titanium"-1 GHz-Powerbook with OS X 10.2.6.

Did I make an error while building the new NeoOffice, or was it a bug in the setup- oder graphical routine?

Thomas
Back to top
OPENSTEP
The One
The One


Joined: May 25, 2003
Posts: 4752
Location: Santa Barbara, CA

PostPosted: Sat Jun 07, 2003 11:13 am    Post subject: Reply with quote

This is probably one of two things:

ATSUI - I did the context-aware ATSUI routines a while ago, but I've still not been quite able to get all the font metrics working properly. I thought the problems were isolated to Writer's metrics, but I recently saw issues inside of Impress as well.

CoreGraphics conversion - If you're seeing overlapping text, it may be due to our shift from QuickDraw to CoreGraphics. We've had some clip region issues we need to take a look at as well as invalidation. You'll also notice that buttons are moving outside of where they should be...Dan's gotten rid of the Appearance Manager stuff and now we're starting to use native controls directly.

I actually haven't run setup in a long time...I tend to rebuild and then copy in the dylibs from solver I know changed into a working binary. After I start nailling some of the graphics problems within the main app I'll go retry setup and see if they're fixed there too.

ed
Back to top
View user's profile Send private message Visit poster's website AIM Address
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> NeoOffice/C Testing All times are GMT - 7 Hours
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.03 Seconds