Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2017? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - dlcompat install fails in 1.03/Panther
dlcompat install fails in 1.03/Panther
 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> OpenOffice.org MacOS X X11 Support
View previous topic :: View next topic  
Author Message
edgreenberg
Blue Pill


Joined: Mar 17, 2004
Posts: 2

PostPosted: Wed Mar 17, 2004 9:01 pm    Post subject: dlcompat install fails in 1.03/Panther Reply with quote

I'm trying to install OOO 1.03. My config is a G3 with 256mb and Panther with the Apple X11 from disk 3.

The install fails at dlcompat, and the message is that libdl installation failed.

Nothing goes to the system console when this happens.

Any idea what might be wrong?

Thanks,
</edg>
Back to top
View user's profile Send private message
OPENSTEP
The One
The One


Joined: May 25, 2003
Posts: 4752
Location: Santa Barbara, CA

PostPosted: Wed Mar 17, 2004 9:51 pm    Post subject: Reply with quote

What you'll want to do on Panther systems is to 'bypass' the libdl installation. Panther has its own libdl. Unfortunatley, it came out after our 103GM installer and the OOo installer isn't aware of what to do. The trick is to make symbolic links for libdl in the expected location "/usr/local/lib" that map to the default Panther location of "/usr/lib".

Do the following in a Terminal but be very careful...after the sudo you are root and can really mess up your computer if you're not careful:

Code:

sudo bash
cd /usr
mkdir local
cd local
mkdir lib
cd lib
ln -s /usr/lib/libdl.dylib libdl.dylib
ln -s /usr/lib/libdl.0.dylib libdl.0.dylib
exit


If you do the above and then rerun the OOo 103GM installer it should no longer attempt to install dlcompat Smile

ed
Back to top
View user's profile Send private message Visit poster's website AIM Address
Guest






PostPosted: Thu Mar 18, 2004 10:24 am    Post subject: Reply with quote

Thank you. I will try this tonight and report back.

Fortunately, I'm much more at home in Unix than in the Mac OS, so the root privs do not worry me much :)


</edg>
Back to top
edgreenberg
Blue Pill


Joined: Mar 17, 2004
Posts: 2

PostPosted: Thu Mar 18, 2004 8:25 pm    Post subject: dlcompat solved - now ghostscript Reply with quote

Well, I get a similar error for Ghostscript, but in this case, the error message is too big to read in the OOo dialog box.

I can compile it myself, but should I have to ?

</edg>
Back to top
View user's profile Send private message
OPENSTEP
The One
The One


Joined: May 25, 2003
Posts: 4752
Location: Santa Barbara, CA

PostPosted: Fri Mar 19, 2004 10:43 am    Post subject: Reply with quote

No, you shouldn't have to worry about ghostscript. It's funny that the ESP Ghostscript installer should be failing too...perhaps something changed in the way I need to invoke Apple Installer that's breaking all the external installers under Panther Sad

You'll want to get ESP Ghostscript 7.05:

http://prdownloads.sourceforge.net/gimp-print/espgs-7.05.6.ppc.dmg?download

For some reason the ESP installer isn't available directly from esp any longer, so the URL in that error message may be out of date.

If all of the external installers are hosed, you'll probably also want to manually get and install fondu as well so you can do the font conversions to import Mac OS X fonts into the OpenOffice.org environment:

http://fondu.sourceforge.net/Fondu-030428.pkg.sit

If you already have X11 installed on Panther, those two installers and the dlcompat symlinks should be all that you need.

Out of curiousity, what version of Panther are you trying to run the 103GM installer on? I tried the full installer on WWDC 03 builds and everything was fine, but something may have changed in the meantime. I'm working on putting together a 1.1.1 installer and would love to try and figure out what I need to change to get these external packages to install correctly Smile

ed
Back to top
View user's profile Send private message Visit poster's website AIM Address
Terry Teague
Guest





PostPosted: Fri Mar 19, 2004 5:38 pm    Post subject: Re: OOo 1.0.3GM on Panther Reply with quote

OPENSTEP wrote:
Out of curiousity, what version of Panther are you trying to run the 103GM installer on? I tried the full installer on WWDC 03 builds and everything was fine, but something may have changed in the meantime. I'm working on putting together a 1.1.1 installer and would love to try and figure out what I need to change to get these external packages to install correctly Smile

Not sure why the user had problems either - I have installed OOo 1.0.3GM onto fresh installs of Panther several times, without problem. Admittedly I haven't tried lately with Panther updates.

Here is a sample partial installation log :

Code:
Install Begin: Wed Oct 29 23:59:49 PST 2003
Install End:   Thu Oct 30 00:05:07 PST 2003

Created with Zero G's InstallAnywhere 5.0.7 Mac OS X Build 1680

Summary
-------

Installation: Successful.

1961 SUCCESSES
0 WARNINGS
0 NONFATAL ERRORS
0 FATAL ERRORS

...

Execute Target File:      DLCompat-20020913-10.2.pkg
                          Status: SUCCESSFUL

...

Execute Target File:      ESP Ghostscript.mpkg
                          Status: SUCCESSFUL

...

Execute Target File:      Fondu-021223.pkg
                          Status: SUCCESSFUL

Execute Command:          /bin/rm -rf "$USER_INSTALL_DIR$$/$ExternalInstallers"
                          Status: SUCCESSFUL

...
Back to top
gaston
Blue Pill


Joined: Mar 21, 2004
Posts: 1

PostPosted: Sun Mar 21, 2004 7:37 pm    Post subject: Reply with quote

I got the first error, added those lines, and the installer no longer offered the dlcompat as an option.

All seemed well.

But, then the next thing happened - the GhostScript Installer didn't install correctly.

I'm currently downloading it, and will report back.

Have to say, though, I was thrilled to find the answer to the first problem so quickly.

Thank's.

--

Right. So the external installers aren't doing whatever they're supposed to.

The GhostScript thing worked, now I'm just trying to find fondu. (http://fondu.sourceforge.net/Fondu-030428.pkg.sit isn't there anymore.)

--

Installed without Fondu.

It works!!

This puts me in such a great mood...
Back to top
View user's profile Send private message
OPENSTEP
The One
The One


Joined: May 25, 2003
Posts: 4752
Location: Santa Barbara, CA

PostPosted: Sun Mar 21, 2004 10:27 pm    Post subject: Reply with quote

Man, bummer that it seems that the OS X fondu installers have been pulled from the open market. I posted an earlier version on the ftp.neooffice.org FTP server.

Name: Fondu-021224.pkg.tar.gz
MD5Sum: 16cd852168d7c4dcc1586563362126d8

That's the package that's used by the OOo 103GM installer. I don't know why the newer installers were pulled by the fondu project, but hopefully this one will suffice Smile

ed
Back to top
View user's profile Send private message Visit poster's website AIM Address
Alondra
Guest





PostPosted: Tue Apr 06, 2004 11:01 pm    Post subject: Reply with quote

I am getting the exact same errors, but in Jaguar. Should I proceed in the same way?

Jasta
Back to top
sardisson
Town Crier
Town Crier


Joined: Feb 01, 2004
Posts: 4588

PostPosted: Wed Apr 07, 2004 1:59 am    Post subject: Fondu there again Reply with quote

OPENSTEP wrote:
I don't know why the newer installers were pulled by the fondu project, but hopefully this one will suffice Smile

ed


There seems to be a new (and recent, as in soon after reports of the the older one vanishing) version available now: http://fondu.sourceforge.net/Fondu-040324.pkg.sitx

It doesn't show up on the sourceforge project page, but it is listed in the downloads section of the fondu homepage(?), http://fondu.sourceforge.net/index.html#Downloads

Smokey
Back to top
View user's profile Send private message Visit poster's website
OPENSTEP
The One
The One


Joined: May 25, 2003
Posts: 4752
Location: Santa Barbara, CA

PostPosted: Wed Apr 07, 2004 10:33 pm    Post subject: Reply with quote

Thanks for finding out where that package was. I myself didn't thoroughly examine their site. You can successfully use OOo without fondu.

If any of the external installers are giving you problems in the 103GM IA installer, you can either try installing newer versinos of the packages or you can turn the packages off. There should be a summary panel before installation that is set to "Typical" by default. It shows all of the other installers that will be attempted to be executed. If you uncheck any of them in that list, they'll simply be skipped during installation.

ed
Back to top
View user's profile Send private message Visit poster's website AIM Address
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> OpenOffice.org MacOS X X11 Support All times are GMT - 7 Hours
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.02 Seconds