Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2022? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - NeoWiki sandbox server running
NeoWiki sandbox server running
 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> NeoWiki and Website Development
View previous topic :: View next topic  
Author Message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11932

PostPosted: Wed Jul 25, 2007 8:21 am    Post subject: NeoWiki sandbox server running Reply with quote

FYI. Using a database backup of the production NeoWiki that JakeOSX sent us, Ed and I have setup a NeoWiki sandbox server at the following URL:

http://neowiki-test.neooffice.org/

To access this sandbox server, your browser will ask you for a user name and password the first time you go to this site. Enter neowikitest for both. The user name and password requirement keeps search engines from indexing the content of this server.

Please note that none of the images in the production NeoWiki are in the sandbox yet (we are trying to figure out the best way to copy those over). However, logins, e-mail, and the other Wiki functions should work.

If anyone has time over the next couple weeks, please test it out and see if you find any breakage in the operation of this sandbox server. Once we identify and fix any obvious problems, we will be moving the production NeoWiki from JakeOSX's server to our higher bandwidth and faster servers.

In other words, the sandbox is for testing the Wiki software so you can put all sorts of garbage content in the sandbox. Production is still on JakeOSX's server and we will make our move based on his server's data. The sandbox data will never be copied into the production NeoWiki.

Patrick
Back to top
View user's profile Send private message Visit poster's website
sardisson
Town Crier
Town Crier


Joined: Feb 01, 2004
Posts: 4588

PostPosted: Wed Jul 25, 2007 8:56 am    Post subject: Reply with quote

The Spanish Main Page (Páginia Principal in the real wiki) is completely missing from the sandbox, and I don't see a deletion record for it Sad —see the red link at the top of the sandbox Main Page.

Actually, it looks like a number of articles in the French wiki are missing, too.

Compare the links on the sandbox with the wiki; there are a bunch of red (missing article) links on the sandbox version Sad

Smokey

_________________
"[...] whether the duck drinks hot chocolate or coffee is irrelevant." -- ovvldc and sardisson in the NeoWiki
Back to top
View user's profile Send private message Visit poster's website
OPENSTEP
The One
The One


Joined: May 25, 2003
Posts: 4752
Location: Santa Barbara, CA

PostPosted: Wed Jul 25, 2007 9:07 am    Post subject: Reply with quote

Thanks for noticing the dropped links. Right now the sandbox should be running the wiki content as of a few weeks ago... There were some encoding problems importing the database and a mediawiki update so I'll check to see which portion of that process is horking the db.

ed
Back to top
View user's profile Send private message Visit poster's website AIM Address
mickeyinlalaland
Oracle


Joined: Feb 18, 2007
Posts: 239
Location: LaLaLand

PostPosted: Wed Jul 25, 2007 9:37 am    Post subject: Reply with quote

French page is not registering accents on this main page - and the linked headers for these categories on each page is doing the same, however, the main body of text within each category is reading accents correctly:
http://neowiki-test.neooffice.org/index.php/Category:NeoWikiFR

where as this is fine on the main wiki:
http://neowiki.neooffice.org/index.php/Category:NeoWikiFR

Missing files on main wikitest for the Front French Page (note red text)
http://neowiki-test.neooffice.org/index.php/Fr:Accueil

Original articles:
Accès Anticipé à NeoOffice FAQ (4th item on top header)
http://neowiki-test.neooffice.org/index.php/Fr:Accueil

Article 2
Comparaison des fonctionnalités
http://neowiki.neooffice.org/index.php/Fr:Comparaison_des_fonctionnalit%C3%A9s

Article 4
Problèmes d'installation et solutions
http://neowiki.neooffice.org/index.php/Fr:Probl%C3%A8mes_d%27installation_de_NeoOffice

Article 5
Problèmes communs et solutions
http://neowiki.neooffice.org/index.php/Fr:Guide_de_d%C3%A9pannage

Article 8
Captures d'écran de NeoOffice
http://neowiki.neooffice.org/index.php/Fr:Captures_d%27%C3%A9cran_de_NeoOffice

Article 9
Comment signaler des problèmes
http://neowiki.neooffice.org/index.php/Fr:Comment_rapporter_des_probl%C3%A8mes_rencontr%C3%A9s_avec_NeoOffice
Back to top
View user's profile Send private message
mickeyinlalaland
Oracle


Joined: Feb 18, 2007
Posts: 239
Location: LaLaLand

PostPosted: Wed Jul 25, 2007 9:42 am    Post subject: Reply with quote

German section appears to be missing only one article
http://neowiki-test.neooffice.org/index.php/De:Hauptseite

Article 4
Installationsprobleme und Lösungen
Original
http://neowiki.neooffice.org/index.php/De:Installationsprobleme_und_L%C3%B6sungen
Back to top
View user's profile Send private message
mickeyinlalaland
Oracle


Joined: Feb 18, 2007
Posts: 239
Location: LaLaLand

PostPosted: Wed Jul 25, 2007 10:10 am    Post subject: Reply with quote

Italian section appears to be missing a few too, however, these links are missing from the main wiki

Section 2:
OpenOffice.org per Mac OS X

Article 3
FAQ per OO.oX11 2.0

Article 4
OpenOffice.org X11
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11932

PostPosted: Wed Jul 25, 2007 2:03 pm    Post subject: Reply with quote

OK. I dropped the sandbox database and reimported JakeOSX's backup. This time, I noticed that there were some import errors so, after some fussing, I got the import to run with no errors.

Please clear your browser's cache and see if any of the problems are fixed. Note that there are a few Spanish accents that still are messed up, but those may need to be fixed manually as the database backup file seems to have inconsistent character encodings for some database records.

Patrick
Back to top
View user's profile Send private message Visit poster's website
Samwise
Captain Naiobi


Joined: Apr 25, 2006
Posts: 2315
Location: Montpellier, France

PostPosted: Wed Jul 25, 2007 2:18 pm    Post subject: Reply with quote

Even though I emptied my cache, the Spanish wiki still isn't available; I also checked in another browser which I had not used to access the test wiki before with the same results.

Moreover, I noticed that all pages (except protected pages such as the Feature Comparison) can be edited by all users (including those who aren't logged in) !
Back to top
View user's profile Send private message
sardisson
Town Crier
Town Crier


Joined: Feb 01, 2004
Posts: 4588

PostPosted: Wed Jul 25, 2007 2:23 pm    Post subject: Reply with quote

I'm getting sporadic database errors when trying to view pages (or do stuff), like

Code:
A database query syntax error has occurred. This may indicate a bug in the software. The last attempted database query was:

    (SQL query hidden)

from within function "User::edits". MySQL returned error "1054: Unknown column 'user_editcount' in 'field list' (localhost)".


Code:
Database error
A database query syntax error has occurred. This may indicate a bug in the software. The last attempted database query was:

    (SQL query hidden)

from within function "Article::insertOn". MySQL returned error "2006: MySQL server has gone away (localhost)".


I also notice that file uploading is disabled (or at least missing from the "toolbox" sidebar) in the sandbox.

Smokey

_________________
"[...] whether the duck drinks hot chocolate or coffee is irrelevant." -- ovvldc and sardisson in the NeoWiki
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11932

PostPosted: Wed Jul 25, 2007 2:26 pm    Post subject: Reply with quote

Ignore my last post. The missing pages are still missing.

I suspect that something is getting deleted by the MediaWiki upgrade script that must be run to make JakeOSX's backup from MediaWiki 1.6.x work with the MediaWiki 1.10.1. Sad

Patrick
Back to top
View user's profile Send private message Visit poster's website
sardisson
Town Crier
Town Crier


Joined: Feb 01, 2004
Posts: 4588

PostPosted: Wed Jul 25, 2007 2:28 pm    Post subject: Reply with quote

I do have the Spanish main page, and the accents have magically gone back to working (from broken a few minutes ago); did you just revert the database?

Smokey

_________________
"[...] whether the duck drinks hot chocolate or coffee is irrelevant." -- ovvldc and sardisson in the NeoWiki
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11932

PostPosted: Wed Jul 25, 2007 2:34 pm    Post subject: Reply with quote

sardisson wrote:
I do have the Spanish main page, and the accents have magically gone back to working (from broken a few minutes ago); did you just revert the database?


Wow! Yes I did. After I had given up, I did I clean reimport using the same steps that I wrote down for yesterday's import.

It looks like we are going to have problems with accents, but I am most interested at this point if any pages are still missing.

Patrick
Back to top
View user's profile Send private message Visit poster's website
Samwise
Captain Naiobi


Joined: Apr 25, 2006
Posts: 2315
Location: Montpellier, France

PostPosted: Wed Jul 25, 2007 2:51 pm    Post subject: Reply with quote

Spanish is back, but unresgistered edits are still working - notice something different on the front page (and see the history) ?
Back to top
View user's profile Send private message
valterb
The Anomaly
(earlier version)


Joined: Sep 23, 2005
Posts: 463
Location: San Giuliano Terme, Pisa, Italy

PostPosted: Wed Jul 25, 2007 3:12 pm    Post subject: Reply with quote

mickeyinlalaland wrote:
Italian section appears to be missing a few too, however, these links are missing from the main wiki

I corrected missing links

Valter
Back to top
View user's profile Send private message Visit poster's website AIM Address
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11932

PostPosted: Wed Jul 25, 2007 4:36 pm    Post subject: Reply with quote

valterb wrote:
mickeyinlalaland wrote:
Italian section appears to be missing a few too, however, these links are missing from the main wiki

I corrected missing links

Valter


I wouldn't spend much effort correcting the data at this point as I will likely keep doing reloads of the backup to make sure that I have a complete set of steps for when we move the production NeoWiki.

Patrick
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> NeoWiki and Website Development All times are GMT - 7 Hours
Goto page 1, 2, 3  Next
Page 1 of 3

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.03 Seconds