Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Problems after upgrading to Sierra or High Sierra? Try these steps
Problems after upgrading to NeoOffice 2017? Try these steps
Download or installation problems? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - Starting document with a defined page number
Starting document with a defined page number
 
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Releases
View previous topic :: View next topic  
Author Message
warewolf
Red Pill


Joined: Aug 27, 2008
Posts: 8

PostPosted: Wed Jul 08, 2009 2:37 pm    Post subject: Starting document with a defined page number Reply with quote

Say I want to start chapter 12 with page 108 and continue on with 109, 110 etc.

I start with Text Document. Then I Insert Header, type book title using Times New Roman font, then go to the body of the document and change font to Courier 12; choose double spacing and choose page attributes, clicking ok when required.

Next, ten double spaces down on the first page, I type in Chapter Twelve, and two double spaces down from that write the first paragraph. Then I go up to Paragraph, choose Text Flow, insert page number 108 and click ok.

But when I click into the first paragraph of the chapter, choose Insert and click Page Number from Fields, that paragraph, preceded by 108, shoots to the top of a NEW page, and the ORIGINAL page, which is now above it and includes the chapter heading, will only accept a page number of 1.

Does anybody have a solution to this problem???

Thank you,
Joyce W.
Back to top
View user's profile Send private message
narf
The Anomaly


Joined: Jan 21, 2007
Posts: 1075

PostPosted: Wed Jul 08, 2009 2:49 pm    Post subject: Reply with quote

Moved to NeoOffice support.
--fran
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11827
Location: California, USA

PostPosted: Wed Jul 08, 2009 3:07 pm    Post subject: Reply with quote

Try the following steps:

If you want the first page to have a specific page to start from a non-default number, here is how you do it:

1. Position the cursor at the very start of the page that you want to have the non-default number, and select the Insert :: Manual Break menu

2. In the dialog that appears, check the Page Break option, select First Page as the style, check the Change Page Number checkbox, set the text field below it to the starting page number that you want, and click the OK button.

3. Make sure the cursor is still after the page break that you just inserted and select the Insert :: Header :: First Page menu to display a header and Insert :: Footer :: First Page to display a footer. Note that selecting these menus will display a headers and footers that are unique to pages after the page break. Also note that if you put the cursor in these headers or foots and select the Insert :: Fields :: Page Number field, the second page will have the page number that you entered.

Does that work for you?

Patrick
Back to top
View user's profile Send private message Visit poster's website
warewolf
Red Pill


Joined: Aug 27, 2008
Posts: 8

PostPosted: Thu Jul 09, 2009 1:54 pm    Post subject: Reply with quote

Sorry, Patrick. I couldn't make your solution work, but I appreciate your taking the time to answer.

Best,
Joyce W.
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11827
Location: California, USA

PostPosted: Thu Jul 09, 2009 2:11 pm    Post subject: Reply with quote

warewolf wrote:
Sorry, Patrick. I couldn't make your solution work, but I appreciate your taking the time to answer.


Can you tell us what results you are seeing with my steps? We might be able to figure out new steps from what you are seeing versus what I am seeing.

I don't know if it helps, but my steps probably will only work if you start with a new document and have not set the page number in the Text Flow panel.

Patrick
Back to top
View user's profile Send private message Visit poster's website
warewolf
Red Pill


Joined: Aug 27, 2008
Posts: 8

PostPosted: Fri Jul 10, 2009 2:34 am    Post subject: Reply with quote

Thanks for persevering, Patrick. I can't write a full reply until later today, but I can't help wishing page numbering in Neo Office was as easy as it is AppleWorks.

Hanging in there,
Joyce W.
Back to top
View user's profile Send private message
warewolf
Red Pill


Joined: Aug 27, 2008
Posts: 8

PostPosted: Fri Jul 10, 2009 12:53 pm    Post subject: Reply with quote

Patrick, when I follow your steps, the number I want on the 1st page appears on the 2nd page AND on the succeeding pages. The only way I can get the numbers to advance is by using the Text Flow panel.

There seems to be no way to get the 1st page number on the actual first page, so I will simply allow the 2nd page to become the 1st page and discard the numberless actual first page when I print out chapters.

Thanks again, and I should add that except for this problem I like NeoOffice very much.

Best,
Joyce W.
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11827
Location: California, USA

PostPosted: Fri Jul 10, 2009 1:24 pm    Post subject: Reply with quote

warewolf wrote:
Patrick, when I follow your steps, the number I want on the 1st page appears on the 2nd page AND on the succeeding pages. The only way I can get the numbers to advance is by using the Text Flow panel.

There seems to be no way to get the 1st page number on the actual first page, so I will simply allow the 2nd page to become the 1st page and discard the numberless actual first page when I print out chapters.


OK. I now understand the problem. My original steps only work when you want to reset the page number in the middle of your document.

NeoOffice's underlying OpenOffice.org code really makes setting the first page number difficult but I was able to get the first page to start at pge 108 by doing the following steps. Note that I started with an empty document so you may want to try creating a new, empty document, following these steps, and then copy of paste your document content into the new document so that you don't mess up your existing document:

1. Select the File :: New :: Writer menu to create a new, empty document with no headers

2. Select the Format :: Styles and Formatting menu. In the floating window that appears, click on the Paragraph Styles icon in the floating window's toolbar.

3. In the Paragraph Styles list, select Default and then Control-click on Default. In the popup dialog that appears, select the Modify option.

4. In the dialog that appears, click on the Text Flow tab and set the starting page number like you have before.

5. Use the File :: Insert :: Header menu to insert a header and then use the Insert :: Fields :: Page Number menu to insert the page number in the header.

At this point, the page number field in the header should say 108. Now you should be able to copy and paste your document's content into the new file.

One important thing, however, is that it seems that once you have content in your document, setting the starting page number is nearly impossible.

Patrick
Back to top
View user's profile Send private message Visit poster's website
warewolf
Red Pill


Joined: Aug 27, 2008
Posts: 8

PostPosted: Sat Jul 11, 2009 8:06 am    Post subject: Reply with quote

Sorry, Patrick. This time, all went well until I copied and tried to paste a page I'd already written into the new first page with #108 in the header.

Disaster: The page I copied and attempted to paste somehow got broken into segments. each segment printed on a succeeding page. but each with number 108 in the header.

I can't believe I'm the only NeoOffice user trying to write a book in chapters requiring succeeding page numbers. This is a problem worth addressing.

Again, thanks for trying,
Joyce W.
Back to top
View user's profile Send private message
shades
Keymaker


Joined: Aug 18, 2005
Posts: 96

PostPosted: Sat Jul 11, 2009 8:24 am    Post subject: Reply with quote

Just a thought. Since this is a field with the section numbering, perhaps it is losing that with the copy from another document, and becoming strictly text rather than updating as a field.

Perhaps this will help: Working with Fields
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11827
Location: California, USA

PostPosted: Sat Jul 11, 2009 9:11 am    Post subject: Reply with quote

warewolf wrote:
Disaster: The page I copied and attempted to paste somehow got broken into segments. each segment printed on a succeeding page. but each with number 108 in the header.


IIRC, you said that in your original document you had the set the Text Flow panel's settings. I suspect that those settings that you changed are being copied with your copied document content and are overriding the settings that my steps set.

Can you attach the new document that you created? Then we can see figure out how to undo any of the overriding settings that are being copied in. You can attach a file using the steps in this forum topic.

Patrick
Back to top
View user's profile Send private message Visit poster's website
warewolf
Red Pill


Joined: Aug 27, 2008
Posts: 8

PostPosted: Sat Jul 11, 2009 12:28 pm    Post subject: Reply with quote

Patrick, since posting my reply telling of disaster, I tried various combinations of header, text flow, etc. etc. and finally came up with a solution that is very simple:

1) With cursor at top of first document page, go to Insert menu and choose Header. Then return to Insert menu, choose Fields, then Page number. The number 1 will appear in header.

2) Go to top of first document page, then to Insert menu, choose Fields and click on Page number. The number 1 will appear on left top of page.

3) Then go to Format, choose Paragraph and click on Text Flow. Insert the page number wanted for first page--in this case 108--into Page number box, clcik OK and, Voila! #108 will supplant #1 both in header and at top of page.

4) Delete number at top of page and type/paste in text. The following pages will be numbered 109, 110 etc.

Now we can both rest,
Joyce W.
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11827
Location: California, USA

PostPosted: Sat Jul 11, 2009 12:52 pm    Post subject: Reply with quote

I am glad that you found a way to make this work and thank you for posting the steps that you used. I think your steps will prove to be very helpful for other users who are trying to figure out the unintuitive steps that are needed to set the first page number.

Patrick
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Releases All times are GMT - 7 Hours
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.03 Seconds