Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2017? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - Small changes to "futureproof" NeoOffice
Small changes to "futureproof" NeoOffice
 
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Testing
View previous topic :: View next topic  
Author Message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11914
Location: California, USA

PostPosted: Sat Oct 27, 2012 10:51 am    Post subject: Small changes to "futureproof" NeoOffice Reply with quote

While working on implementing Mac OS X's application sandboxing, I found a few places in the NeoOffice code that uses Mac OS X functions that Apple has marked as "deprecated".

Usually, when Apple marks a function as deprecated, it means that the function will likely be removed in a future version of Mac OS X so, to be safe, we reimplement any code that uses deprecated to help ensure that NeoOffice will be able to run on future versions of Mac OS X.

In the following test patch, I have reimplemented the following NeoOffice code:

- Resolution of Finder alias files
- Determining the correct folder for NeoOffice Mobile and patch checking downloads
- Launching NeoOffice without reexecuting the soffice.bin command

If anyone can you install the following test patch and tell us if NeoOffice no longer launches or you are unable to download documents from within NeoOffice Mobile, that would be greatly appreciated:

Intel:
http://sally.neooffice.org/test/NeoOffice-3.3-Patch-2-Test-5-Intel.dmg

Patrick
Back to top
View user's profile Send private message Visit poster's website
djpimley
The Anomaly
(earlier version)


Joined: Jun 11, 2006
Posts: 481
Location: Great Britain

PostPosted: Sat Oct 27, 2012 11:41 am    Post subject: Reply with quote

Installed, launched NeoOffice and opened some documents. No issues on 10.8.2.

Mobile not tested.
Back to top
View user's profile Send private message Visit poster's website
ovvldc
Captain Naiobi


Joined: Sep 13, 2004
Posts: 2352
Location: Zürich, CH

PostPosted: Sun Oct 28, 2012 6:23 am    Post subject: Reply with quote

Same on 10.6.8 for me Smile.
_________________
"What do you think of Western Civilization?"
"I think it would be a good idea!"
- Mohandas Karamchand Gandhi
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11914
Location: California, USA

PostPosted: Sat Nov 03, 2012 12:01 pm    Post subject: Reply with quote

FYI. I found that the code in the last test patch causes a slight decrease in file access speed so in the following test patch, I tweaked my code changes to match the speed of the old code:

Intel:
http://sally.neooffice.org/test/NeoOffice-3.3-Patch-2-Test-7-Intel.dmg

Patrick
Back to top
View user's profile Send private message Visit poster's website
ovvldc
Captain Naiobi


Joined: Sep 13, 2004
Posts: 2352
Location: Zürich, CH

PostPosted: Sun Nov 04, 2012 10:48 am    Post subject: Reply with quote

Well, it still opens files and does so quite smoothly and quickly, so I am pretty happy with it Smile.

Do I need to test saving and/or converting as well?

_________________
"What do you think of Western Civilization?"
"I think it would be a good idea!"
- Mohandas Karamchand Gandhi
Back to top
View user's profile Send private message
djpimley
The Anomaly
(earlier version)


Joined: Jun 11, 2006
Posts: 481
Location: Great Britain

PostPosted: Sun Nov 04, 2012 2:34 pm    Post subject: Reply with quote

Latest patch is good for me, as before.
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11914
Location: California, USA

PostPosted: Wed Nov 07, 2012 8:58 pm    Post subject: Reply with quote

FYI. I found a few more Mac OS X functions that NeoOffice uses that Apple has marked as deprecated. So, I have reimplemented the following NeoOffice code to help ensure that NeoOffice will be able to run on future versions of Mac OS X:

- Loading of OpenSymbol font bundled with NeoOffice as well as any custom fonts in the user's ~/Library/Preferences/NeoOffice-3.0/user/fonts folder

- Detecting adding, removing, enabling, or disabling of fonts in the Font Book application

- Hiding the Mac menubar and Dock when running a slideshow in Impress

- Detecting the user's double-click time interval as set in the System Preferences application

If anyone can you install the following test patch and tell us if NeoOffice displays the wrong or no symbol for the bullet symbol in lists in Writer, if the Mac menubar and/or Dock appear when running a slideshow in Impress, or if double-clicking is much faster or slower than in Apple applications, that would be greatly appreciated:

Intel:
http://sally.neooffice.org/test/NeoOffice-3.3-Patch-2-Test-8-Intel.dmg

Patrick
Back to top
View user's profile Send private message Visit poster's website
ovvldc
Captain Naiobi


Joined: Sep 13, 2004
Posts: 2352
Location: Zürich, CH

PostPosted: Fri Nov 09, 2012 2:31 am    Post subject: Reply with quote

I tested all three of the things you asked for and they seem fine on my OS X 10.6.8 machine Smile.
_________________
"What do you think of Western Civilization?"
"I think it would be a good idea!"
- Mohandas Karamchand Gandhi
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11914
Location: California, USA

PostPosted: Wed Nov 14, 2012 10:30 pm    Post subject: Reply with quote

FYI. I found a bug in the native open and save dialogs in the last test patch. When the current folder in either dialog had a softlink or alias that linked to a non-existent file or folder, our code would go into an infinite loop and NeoOffice would hang so I have fixed this bug and the fix is in the following test patch:

Intel:
http://sally.neooffice.org/test/NeoOffice-3.3-Patch-2-Test-12-Intel.dmg

Patrick
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11914
Location: California, USA

PostPosted: Wed Jan 30, 2013 11:30 pm    Post subject: Reply with quote

FYI. I found a few more bits of code that NeoOffice uses that Apple has marked as deprecated. So, I have reimplemented the following NeoOffice code to help ensure that NeoOffice will be able to run on future versions of Mac OS X:

- The Gestalt() function (which Apple still has no official replacement for) is now dynamically loaded and reasonable default values are used if it doesn't load (because Apple has removed it).

- Apparently Novell has let the go-oo.org website die and so all of the OpenOffice.org extensions URLs that Novell's Go-oo engineers changed to go-oo.org URLs now fail so I added code to detect and replace any go-oo.org URLs with their matching OpenOffice.org URL

If anyone can install the following test patch and tell us if any extensions or other URLs load non-existent web pages, that would be greatly appreciated:

Intel:
http://sally.neooffice.org/test/NeoOffice-3.3-Patch-4-Test-2-Intel.dmg

Patrick
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11914
Location: California, USA

PostPosted: Mon Feb 04, 2013 6:51 pm    Post subject: Reply with quote

I found a few deprecated functions in our code that plays video and so, in the following test patch, I have made a few small changes to that code to eliminate all deprecated functions.

If anyone who can test both playing a video in Writer and Impress documents and tell us if their videos still work, that would be very much appreciated:

Intel:
http://sally.neooffice.org/test/NeoOffice-3.3-Patch-4-Test-3-Intel.dmg

Patrick
Back to top
View user's profile Send private message Visit poster's website
ovvldc
Captain Naiobi


Joined: Sep 13, 2004
Posts: 2352
Location: Zürich, CH

PostPosted: Tue Feb 05, 2013 2:24 am    Post subject: Reply with quote

hey Patrick,

I tried with two video files, once the .mov files you can download from http://vimeo.com/1211060, and one a video message I recorded with photo booth for my cousin when I couldn't attend his wedding.

Unfortunately, they refused to play both in Writer and Impress. In both cases, I would click the play button in the small toolbar, and even though the speaker plops ever so slightly to indicate audio is activated, the stop button never releases and no media play Sad.

Using the latest NeoOffice with your patch on OS X 10.6.8. I get the following messages in my console.log:

Code:
05-02-13 11:15:19   defaults[30877]   
The domain/default pair of (org.neooffice.NeoOffice, updateSuppressLaunchAfterInstallation) does not exist
05-02-13 11:16:58   [0x0-0x47e47e].org.neooffice.NeoOffice[30879]   -->com.sun.star.comp.avmedia.Manager_QuickTime uno reference
05-02-13 11:17:37   [0x0-0x47e47e].org.neooffice.NeoOffice[30879]   -->com.sun.star.comp.avmedia.Manager_QuickTime uno reference
05-02-13 11:18:18   [0x0-0x47e47e].org.neooffice.NeoOffice[30879]   -->com.sun.star.comp.avmedia.Manager_QuickTime uno reference
05-02-13 11:18:37   [0x0-0x47e47e].org.neooffice.NeoOffice[30879]   -->com.sun.star.comp.avmedia.Manager_QuickTime uno reference

_________________
"What do you think of Western Civilization?"
"I think it would be a good idea!"
- Mohandas Karamchand Gandhi
Back to top
View user's profile Send private message
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11914
Location: California, USA

PostPosted: Tue Feb 05, 2013 9:07 am    Post subject: Reply with quote

ovvldc wrote:
Using the latest NeoOffice with your patch on OS X 10.6.8. I get the following messages in my console.log...


In my haste last night, I failed to mention I found some bugs when using Apple's QuickTime functions on Mac OS X 10.6 Snow Leopard. For some unknown reason and only on Snow Leopard, querying the play time or rate of play while a movie is running causes the current movie to only play for a few seconds. Once this QuickTime bug is triggered, it will keep occurring for that same movie so you must close and reopen the document to reset the movie.

Fortunately, this QuickTime bug is not triggered by running an Impress slide show as long as you don't play the movie in the document. So, on Snow Leopard only, I added code to prevent this bug from being triggered when movies are played during slide slows by forcing the movie to stop and return to the beginning if the OpenOffice.org code queries the play time or ignoring changes to the rate of play while the movie is running. This fix has the effect of disabling playing of movies when not running a slide show for Mac OS X 10.6 Snow Leopard users.

This QuickTime bug does not occur on Mac OS X 10.7 or 10.8 so only Mac OS 10.6 Snow Leopard will see this limitation. I suspect that Apple has made some change to QuickTime recently as I did not see this bug last summer when we first released NeoOffice 3.3.

Patrick
Back to top
View user's profile Send private message Visit poster's website
pluby
The Architect
The Architect


Joined: Jun 16, 2003
Posts: 11914
Location: California, USA

PostPosted: Tue Feb 05, 2013 11:54 am    Post subject: Reply with quote

I think I found a way to get videos to play in a document for Mac OS X 10.6 users without triggering the Snow Leopard QuickTime bug.

Can you install the following test patch and try playing videos? Note: when the "stop" button is set, to play a video you must move the slider to the left of the stop button to a non-zero time first. Then pressing the "play" button will work:

Intel:
http://sally.neooffice.org/test/NeoOffice-3.3-Patch-4-Test-4-Intel.dmg

Patrick
Back to top
View user's profile Send private message Visit poster's website
ovvldc
Captain Naiobi


Joined: Sep 13, 2004
Posts: 2352
Location: Zürich, CH

PostPosted: Tue Feb 05, 2013 12:50 pm    Post subject: Reply with quote

OK, I cannot get the movies to play in a text document or while preparing a presentation, but they start just fine when I run a slide show and open a slide with a movie.

And now I just noticed your new test patch, which I will go and install and try again.

_________________
"What do you think of Western Civilization?"
"I think it would be a good idea!"
- Mohandas Karamchand Gandhi
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NeoOffice Forum Index -> NeoOffice Testing All times are GMT - 7 Hours
Goto page 1, 2  Next
Page 1 of 2

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.06 Seconds