Welcome to NeoOffice developer notes and announcements
Developer notes and announcements

This website is an archive and is no longer active
NeoOffice announcements have moved to the NeoOffice News website

· Forums
· NeoOffice Support
· NeoWiki

· Twitter @NeoOffice

· Download NeoOffice

NeoOffice :: View topic - dyld deadlock issue
dyld deadlock issue
   NeoOffice Forum Index -> OpenOffice.org X11 Testing
View previous topic :: View next topic  
Author Message
Blue Pill

Joined: Aug 17, 2003
Posts: 4

PostPosted: Sun Aug 17, 2003 11:43 am    Post subject: dyld deadlock issue

I just downloaded & installed NeoOffice. I really like having the Ximian icons because the stock OpenOffice 1.0.3 icons are not quite as visually appealing & intuitive (I think). However, I've been having some issues that are preventing me from really being able to use NeoOffice. Here's my config to start off:

PB 12" w/640MB
OS - 10.2.6
Apple X11 installed - I think I installed Xfree using fink at one point as well

I had a preexisting OpenOffice.org 1.0.3 version installed.
Installation location: /Applications/OpenOffice.org1.0.3

I've tried installing NeoOffice several times. The last time, I uninstalled OpenOffice.org & NeoOffice, reinstalled OpenOffice and then installed NeoOffice in the same directory (in order to get the Start OpenOffice App to work correctly)

The installation worked, as was described in the README, but segfaulted after reaching 100%. I copied the 2 files over, as described in the README, and started up NeoOffice using the Start OpenOffice app. I get the following error message in /tmp/Start_000.xxxxxx:

libGL.dylib could not be opened.
supported protocols:
_NET_ACTIVE_WINDOW (unsupported)
_NET_CLIENT_LIST (unsupported)
_NET_CLOSE_WINDOW (unsupported)
_NET_WM_ACTION_CLOSE (unsupported)
_NET_WM_ACTION_MOVE (unsupported)
_NET_WM_ACTION_RESIZE (unsupported)
_NET_WM_ACTION_SHADE (unsupported)
_NET_WM_NAME (unsupported)
Window Manager's name is ""
query subsets failed
Creating Multi-Lingual InputMethod
style #0 = PreeditNone StatusNone
style #1 = PreeditNothing StatusNothing

However, NeoOffice does open up using the Start OpenOffice.org script/app. I can open up Word/text documents w/o any problem. If I try to open up a Excel/Spreadsheet document, the program locks up, CPU utilization goes to 100% and I get the following error in/tmp/Start_000.xxxxx:

dyld: /Applications/OpenOffice.org1.0.3/program/soffice.bin dead lock (dyld operation attempted in a thread already doing a dyld operation)

Any ideas as to what could be wrong?

Back to top
The One
The One

Joined: May 25, 2003
Posts: 4752
Location: Santa Barbara, CA

PostPosted: Sun Aug 17, 2003 12:26 pm    Post subject:

Are you referring to Neo or OOo Brand X? Neo's a double clickable bundle and doesn't have any installer.

Brand X is the X11 graphics based one with the Ximian icons and patches. I just tried opening up excel spreadsheets in it and haven't had any problems.

How much free space do you have on your startup drive for swap space? When any of these apps cause you to run out of swap space/temp space they tend to lock up instead of telling you you're running out of memory. I experience swap space issues if I have less then 1GB free space on my startup disk. BrandX takes slightly more space due to the high-quality icons, and from my experience you should have at least 750 MB free for swap to expand when using multiple parts of it (e.g. spreadsheet + draw, writer + spreadsheet, etc.).

Back to top
Blue Pill

Joined: Aug 17, 2003
Posts: 4

PostPosted: Sun Aug 17, 2003 3:36 pm    Post subject:

Sorry about that. I meant the Brand X. I guess I'm confused as to what NeoOffice is then....

As for the free space on my drive, that shouldn't be a problem. I have a 40GB drive and have 30GB free. Swap space however...I have to claim ignorance. I'm new to OSX and swap confg seems to be different than on linux. Here's the out of my df listing:

Filesystem 1K-blocks Used Avail Capacity Mounted on
/dev/disk0s9 39066000 8749972 30060028 22% /
devfs 94 94 0 100% /dev
fdesc 1 1 0 100% /dev
<volfs> 512 512 0 100% /.vol
automount -fstab [352] 0 0 0 100% /Network/Servers
automount -static [352] 0 0 0 100% /automount

Back to top
The One
The One

Joined: May 25, 2003
Posts: 4752
Location: Santa Barbara, CA

PostPosted: Sun Aug 17, 2003 4:47 pm    Post subject:

Perhaps I should add a FAQ about the different branches....regardless....

(moves topic into X11 forum)

As to opening up an excel doc that exhibits a freeze, can you choose File > New > Spreadsheet and get an empty spreadsheet without a freeze? You may have found a general problem with the excel filters that crashes on specific excel files and is not OS X specific.

Another test strategy is to create an empty document in Excel, save it, and then try to open it in brand x.

Back to top
Blue Pill

Joined: Aug 17, 2003
Posts: 4

PostPosted: Sun Aug 17, 2003 7:12 pm    Post subject:

The freezing seems to occur only on spreadsheets (either openoffice or excel). I tried opening new documents of different types (e.g. Presentation, ,HTML, Equation, Master Document, Business Cards, etc) and I opened them all simultaneously - had 5-6 document windows open. When I try File | New | Spreadsheet ...Brand X freezes. I monitored the /tmp/Start_000.xxxxxxx file that the Start OpenOffice.org app outputs to and the dyld dead lock error appears only when I attempt to open a new or existing spreadsheet. I had the stock OpenOffice.org 1.0.3 installed before and I had been able to work with both Excel & OpenOffice spreadsheets, with no problem.
Back to top
Blue Pill

Joined: Aug 17, 2003
Posts: 4

PostPosted: Mon Aug 18, 2003 8:03 pm    Post subject:


Thanks for the comments so far. I was wondering if there was anything else I should try. Seems that the spreadsheet component is completely unusable at this point. Let me know if there is something else I should be looking for, trying, etc.

thanks again
Back to top
The One
The One

Joined: May 25, 2003
Posts: 4752
Location: Santa Barbara, CA

PostPosted: Mon Aug 18, 2003 9:27 pm    Post subject:

Wow, that is strange...so it definitely seems to be an issue with the spreadsheet stuff. Here's what I'd try next:

Archive away the .sversionrc file (it's in your home directory...you can't see it in the Finder, so you may need to use a Terminal to "cp" or "mv" it away)

Create a new directory in a path that has no spaces in it.

Install Brand X into that fresh directory, e.g. not on top of an existing OOo 103 or Brand X install. This will force the Brand X installer to recreate all of the config and such in that fresh directory for a single user.

Make a copy of Start OpenOffice.org from the old OOo directory into the new one.

Double-click the copy of Start OOo in the new directory.

Try creating a new spreadsheet.

If that works, then we know the problem's lying somewhere in a library that didn't get overwritten or a configuration issue. If the spreadsheet module still doesn't work in that clean installation directory, then we'll have to do a bit more detailed troubleshooting. If it's isolated to "sc" (starcalc) then I suspect the issue may be installing on top of an existing install...I haven't been able to reproduce the Calc problem locally in clean brand x installs on my two 10.2.6 boxen (didn't try 10.3 or earlier OS releases, but that shouldn't be the issue if it's just deadlocking for each spreadsheet).

Back to top
Display posts from previous:   
   NeoOffice Forum Index -> OpenOffice.org X11 Testing All times are GMT - 7 Hours
Page 1 of 1

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.