Welcome to NeoOffice developer notes and announcements
NeoOffice
Developer notes and announcements
 
 

Download or installation problems? Try these steps
Problems after upgrading to NeoOffice 2022? Try these steps


Support
· NeoOffice Support
· NeoWiki


Announcements
· Twitter @NeoOffice


Downloads
· Download NeoOffice


RSS Feeds
· Announcements Only
· All Posts


  
NeoOffice :: View topic - OOo 1.1.2 RC 2 Installer for Test
OOo 1.1.2 RC 2 Installer for Test
 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> OpenOffice.org X11 Testing
View previous topic :: View next topic  
Author Message
Guest






PostPosted: Mon May 31, 2004 3:13 pm    Post subject: Re: fly-outs Reply with quote

OPENSTEP wrote:
Anonymous wrote:
button in the toolbar and select something WITHOUT it 'tearing off' right away. This worked in 1.0.3.


This was actually a behaviour change between 1.0 and 1.1 that was made for all Unix platforms



I just checked OO 1.1.1 included with SuSE 9.1, and its behaviour is identical to 1.1.2 Mac, as you said. I like that the torn-off palettes are not longer captive to the document window, but wish the 'fly-out' still worked with the 'tear-off' being an option. I'll file a bug at OO.org.


OPENSTEP wrote:
Anonymous wrote:
Along those lines, the mouseover help for the top item in the sidebar just says 'Insert' when it should say 'Insert Table' .


Can you file this in the main OOo bugzilla database? It's probably incorrect on all platforms, not just Mac.

ed


You're right, it's incorrect on the SuSE install I mentioned above, and if a bug hasn't already been filed on it, I'll do it.

Thanks,
Back to top
OPENSTEP
The One
The One


Joined: May 25, 2003
Posts: 4752
Location: Santa Barbara, CA

PostPosted: Mon May 31, 2004 9:10 pm    Post subject: Re: dlcompat Reply with quote

Terry Teague wrote:
I don't know if the simple act of launching OOo (via "Start OpenOffice.org") which sets the DYLD_LIBRARY_PATH to include OOo is sufficient to satisfy windowmaker's libdl needs or not - sounds a little like Russian Roulette to me.

I typically build OOo with libdl on my system, and install libdl onto systems on which I run OOo.

I think we need to rethink this a bit.


Wonk, Terry...I think you hit the nail on the head with that one. I hadn't even considered the possibility of the ancillary applications requiring libdl...most other installers aren't also terribly stringent about their dependency checking Sad

How about this solution: re-insert dlcompat for 10.2 systems. On a 10.3 system, if there is no /usr/local/lib/libdl.0.dylib make appropriate symbolic links into /usr/lib. The installer's already doing a similar fix for pstoprint -> ps2print, so it's a no brainer. If the links are there then all of the ancillary software should work on a 10.2 system and cover any additional creep into software used on a 10.3 system.

ed
Back to top
View user's profile Send private message Visit poster's website AIM Address
OPENSTEP
The One
The One


Joined: May 25, 2003
Posts: 4752
Location: Santa Barbara, CA

PostPosted: Mon May 31, 2004 9:16 pm    Post subject: Reply with quote

Anonymous wrote:
OPENSTEP wrote:
Quote:

Quote:
Anonymous wrote:
this version does NOT have the command-key mappings appropriate for OS X.


Are you using Apple X11 on Panther or one of the XFrees?


Yes, Apple X11 on 10.3.4.


I just went back and checked on my powerbook (10.3.3) and it does appear to not be working properly with apple x11. Note that for it to work the "Enable key equivalents under X11" preference needs to be disabled. I remember testing that on my desktop box, but on my tibook it seems to be broken.

I'll check the patches when I get back to my home base of operations (on partial vacation now...no longer partying, but on wrong coast). I may have not properly run deliver and rebuild the installation set.

ed
Back to top
View user's profile Send private message Visit poster's website AIM Address
Terry Teague
Guest





PostPosted: Mon May 31, 2004 11:57 pm    Post subject: Re: Installer "hangs" on covert_lucida.sh and othe Reply with quote

sardisson wrote:
Finally, during the actual, as both users (multiple times), the installer just hung on the Converting Fonts/convert_lucida.sh stage (having completed it, as far as I can tell). I looked into <OOo>/share/fonts/truetype and noticed no new fonts being added for over 10 minutes, so I then killed the installer. Each time I ran the installer (twice as each user), a different number of fonts were converted. I also noticed that a half-dozen or so fonts were (copied to? mal-fondu'd?) /tmp/font_conversion as 0 byte files (they're most definitely not 0 bytes). Could this be related to the hang?

I too had the Font Conversion hang today. I never experienced it with the OOo 1.0.3GM Installer.

I did a bit of investigation of the problem (and I can send you more details Ed), but I suspect the following line in the "convert_lucida.sh" script is to blame :
Code:
/bin/mv *.ttf "$INSTALL_FOLDER/share/fonts/truetype"

There are sometimes bugs in shells when the command line gets too long. I didn't measure the exact character count of the command line in my case, but there appeared to be quite a lot of fonts to be moved.

And as Smokey said, there were a number of 0 byte files, and other (Asian) fonts that showed up with filenames in Terminal like "????????.ttf" etc.

Rather than doing all the fonts at once :
Code:
/bin/cp /System/Library/Fonts/* .
/bin/cp /Library/Fonts/* .
/bin/cp ~/Library/Fonts/* .

perhaps it would be better to do one Font folder at a time.

FYI, my installation was to a non-boot volume, so "mv" would have to do a "cp" followed by a "rm" (as per the "man" page), in case that is significant.

Regards, Terry
Back to top
sardisson
Town Crier
Town Crier


Joined: Feb 01, 2004
Posts: 4588

PostPosted: Tue Jun 01, 2004 1:01 am    Post subject: Re: Installer "hangs" on covert_lucida.sh and othe Reply with quote

Hi Ed,

Here's the followup to your comments/questions about my feedback (more/longer quotes in here than I'd like, but both posts are now rather far back in the thread...).

OPENSTEP wrote:
sardisson wrote:
First, the installer initially crashed as it was configuring itself (the screen w/progress bar and the OOo Mac OS X (X11) logo)


[...]They said it was a problem in Apple's Java VM and reinstalling Java was reported to have solved the problem for users.


Hmm...that doesn't seem to explain why having logged out and back in enabled it to work for me this time (RC2) around (incidentally, I installed again tonight to double-check a few facts, not having logged out/in since doing so to enable the install the other day, and it ran fine). I wonder if this is possibly related to the situation wherein what was a full java install for 10.2 turned into a partial java install with an upgrade to 10.3 and required some hoop-jumping to get current?

OPENSTEP wrote:
sardisson wrote:
My disk name is not "Mac OS X Startup Disk", which is what the quotes are implying to me (ie, each quoted item is an actual disk/folder name), and this might confuse users.


Good point. I think I'm using the standard IA screen for that panel, and I'm unsure if it will offer me the opportunity to change it to the name of the actual startup disk.


Navigating around the disk and selecting a new location didn't cause the installer to report my disk's actual name, either (and I don't have a second disk to try). If IA won't let you change the name to the disk's actual name, will it let you drop the quotes around it or provide another generic name? That would create a distinction between the named folders in quotes and might help lessen the potential confusion....

OPENSTEP wrote:
sardisson wrote:
or are there options for people who don't have fondu, X11, etc. already?)


Yes, if the auxiliary programs are needed they can be turned on and off through their own checkboxes. This was added so people could choose to use their own versions of helpers [...]


Was I supposed to see those options/checkboxes? As I mentioned in my first post, I essentially have two completely identical options (Typical/Custom) with no checkboxes other than OOo112 or descriptions (the one for OOo112 seems to come and go). Does it detect that I have 10.3 plus an existing fondu install (orig from 1.0.3 GM and later updated to the spring 2004 version from fondu's site)?


OPENSTEP wrote:
sardisson wrote:
the installer "stalls" with no feedback (ie, no beachball) that it's thinking or even that the click has been accepted.


I've seen this on my test box but never saw it as a long pause. It's another ZeroG related bug. I'll troll through their online forums to see if I can find a solution. This is the one that is appearing right before the "Available Space" screen, right? I may be able to just skip that screen.


Yes, this is when 'leaving' the "Choose Subcomponents" screen and awaiting the display of the "Pre-Installation Summary" (listing install location, disk space, etc) screen.

In tonight's install I also noticed a shorter pause following my click on the "Install" button on the "Pre-Installation Summary" screen; nowhere near the 30 or so seconds it pauses trying to leave the "Choose Subcomponents" screen, but just long enough to be noticeable. Since there aren't any more config screens following this latter one, I don't think it really matters.

OPENSTEP wrote:
sardisson wrote:

3. The <OOo> directory and hierarchy are all write-protected [owner=system] ....


Right now the installer does use that 755/644 permissions. They changed in 1.1 for other Unix platforms, and I can understand the security implications that caused that change.

Do you think that making the font directory should be publicly writeable by default would be a reasonable solution? Or is adding fonts a security violation?


I suppose permissions wouldn't matter if fondu always worked correctly and fondu'd 100% of the fonts at OOo install and users never added any more fonts to their system--or if Terry can make Start OOo somehow authenticate to install newly fondu'd fonts. IMHO this is something for you and Terry to coordinate; I don't know enough about the security implications to suggest a default for "average" users, and the rest of us can change permissions for a fondu/Start OOo session if we need to.

OPENSTEP wrote:
sardisson wrote:

5. *Some* existing (non-Mac/Windows) .ttf were not copied to <OOo>/share/fonts/truetype, though others were, with no apparent rhyme or reason to it.


Were these fonts in your OS X directories, or fonts you had previously converted and added to OOo? [...] Logically we should do the conversion as well as move over the fonts from any 1.0.3 installation. I'll make sure to fix that Smile


They were in my OS X (~/Library/Fonts) directories. I've picked up a few here and there ever since certain OS 9 apps (WorldText) started recognizing them, and under X I've stored them in my ~/Library/Fonts directory.

Typing this just caused me to think about another can of worms, Classic. I've got a large number of fonts, actually, in my Classic's font folder. These never got fondu'd the first time around (1.0.3) and fondu'ing them a few weeks ago was what led to my comments to Terry about <OOo>/share/fonts/truetype being "locked".

Classic is a can of worms because 1) users who still use Classic for anything can be installing all of their fonts there so Classic apps can see them, too; 2) there are newer, more advanced versions of many "standard" Classic fonts in the OS X directory (Unicode compatibility, etc.) and for these cases, we wouldn't want the older Classic ones fondu'd; and 3) one can have multiple and/or relocated Classic System Folders (this is the case for me, as I brought over my WallStreet's System Folder and updated it for Classic use).

IMHO probably the easiest way to deal with the Classic Fonts folder is not to fondu fonts installed there but to advise the user to add them manually via Start OOo (once the font directory permissions get worked out)--and not to duplicate any that OOo already shows being installed....

OPENSTEP wrote:

Incredibly so!!! Thanks for the great feedback!!

ed


Glad to be of help; thanks for all the work you (and all the others) do! The availability of NeoJ and pending availability of OOo 1.1.2 (Arabic support!) helped me snare a colleague as a switcher the other day!

...And apologies again for the "excessive quoting" here and my longwindedness. Smile

Smokey


Last edited by sardisson on Fri Oct 08, 2004 2:55 am; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website
chriscaouette
Guest





PostPosted: Wed Jun 02, 2004 7:28 pm    Post subject: edgar111 Reply with quote

I still cannot download anything from ftp://ftp.neooffice.org. Is the server up?
Chris
Back to top
sardisson
Town Crier
Town Crier


Joined: Feb 01, 2004
Posts: 4588

PostPosted: Thu Jun 03, 2004 8:22 pm    Post subject: Re: edgar111 Reply with quote

chriscaouette wrote:
I still cannot download anything from ftp://ftp.neooffice.org. Is the server up?


I believe Ed mentioned that there's a limit of two anonymous connections at a time, so you might not always get in, especially since the download is large and will take some time even with broadband. I just checked, though, and got in, so the server is running.

Smokey
Back to top
View user's profile Send private message Visit poster's website
jakeOSX
Ninja
Ninja


Joined: Aug 12, 2003
Posts: 1373

PostPosted: Fri Jun 04, 2004 8:34 am    Post subject: Reply with quote

that is true, smokey, only two at a time for bandwidth reasons.

just keep giving it a shot, you'll get it....

i think.

-j
(who is still trying..)
Back to top
View user's profile Send private message
sardisson
Town Crier
Town Crier


Joined: Feb 01, 2004
Posts: 4588

PostPosted: Tue Jun 08, 2004 4:21 am    Post subject: Including .weblocs in the installer? Reply with quote

I know the sites are mentioned in the readme, and I imagine there are probably philosophical reasons for (not) doing so, but what about having the installer include a couple of .weblocs in the OOo directory--say, for porting/mac, trinity forums (and/or ooodocs's mac forum)?

The .webloc thing seems to be becoming a fairly common practice these days with Mac sw and is, I think, a user-friendly way of pointing new users to OOo-Mac news/support...

Just a thought...
Smokey
Back to top
View user's profile Send private message Visit poster's website
OPENSTEP
The One
The One


Joined: May 25, 2003
Posts: 4752
Location: Santa Barbara, CA

PostPosted: Tue Jun 08, 2004 9:46 am    Post subject: Reply with quote

Interesting point on the webloc file...I think it's probably a good idea. The OOo mac website is kind of buried within the "porting" project and seems kind of separate from the other portions of the site. It's also quite confusing to navigate, much less search for/post a bug issue with IZ Sad

I think that's a great idea and will try to put one together with the relevant sites Smile

In other news, I'm working on the next build with the latest set of patches for audio and scanning support. Hopefully I should have a new installer available by the end of the week incorporating all of the wonderful changes (and bugs!) found here. Thanks so much dudes!

The goal is to get 1.1.2 out by WWDC Smile

ed
Back to top
View user's profile Send private message Visit poster's website AIM Address
Guest






PostPosted: Thu Jun 10, 2004 5:53 am    Post subject: Reply with quote

Anonymous wrote:
Terry Teague wrote:
Quote:
But that's part of the problem - I am open to constructive criiticism, not random anonymous comments in an online forum. If "Start OpenOffice.org" is a constant source of frustration to your users, why did you not contact me directly with your concerns, which I might have been able to address? [If you are "Len <last-name-deleted>" then you contacted me once, over a year ago, with an initial inquriy to which I responded, and heard no more from you]


What problem?!? I thought this thread was *soliciting* feedback - my mistake.... My comments are the same whether I chose to post anonymously or with a name, and I *did* use my first name in my posting to you. I'm tired of setting up email addresses for forums only to have them become spamtraps, and having had some identity-theft concerns recently I'm trying to minimise spreading my name on too many forums. Thanks a lot for posting my full name without knowing if it was even me you were talking to - moderators: please edit Terry's previous posting to obfuscate my last name, please.

Yes, I contacted you a year ago, and as your answer fully satisfied my question, there was no need for further dialogue. At that time I believed that a non-Aqua/non-X11 version of OO was not so far away, so my initial intent was to run StarOffice/OO remotely from a Solaris box via an exported $DISPLAY (which was the subject of that email to you). Once OO 1.0.3gm was available, I switched to that. Users found using "Start OpenOffice.org" less friendly than what they had been used to under Solaris/KDE, and new hires presented their own training challenges. Being quite preoccupied with deploying and training new hardware/OS/CAD platforms, this "...constant source of frustration..." was put off until I could deal with it, which happens to be now.

So, you have my comments and UI functionality requests which are presumably now legitimised by the fact that I am unwittingly no longer random and anonymous. I hope that you consider them objectively and realise the improved UI by making the app more like the 'quickstarter' available on Win/Linux.

Len


Cant u 2 stop fightin? Smile

When i started wiv OOo, terry's script didnt work so i got Coool which worked fine - hav u tried that? out of interest, y not use Neooffice?
Back to top
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    NeoOffice Forum Index -> OpenOffice.org X11 Testing All times are GMT - 7 Hours
Goto page Previous  1, 2, 3
Page 3 of 3

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © Planamesa Inc.
NeoOffice is a registered trademark of Planamesa Inc. and may not be used without permission.
PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.03 Seconds